Support » Plugin: Facebook Instant Articles & Google AMP Pages by PageFrog » Have to re-enable AMP after each edit

  • Resolved powcom

    (@powcom)


    It seem there’s a problem with PageFrog not remembering the ‘Default setting for new posts’ when updating posts being edited.

    I’m going through all of the posts that are throwing errors on now-AMP-enabled previous posts.

    After I edit what’s needed (YouTube reference / audio shortcodes, etc), I then hit the Update button.

    If I try to look at the /amp/ version, but it defaults back to the non-AMP version.

    This is despite me 1) leaving the AMP options ticked, or 2) changing both of the “Enable this post for: Instant Articles & AMP HTML” checkboxes to Ticked (previously empty) prior to Update.

    If I go back in and re-tick both of those fields, the Update again, the AMP post is then there.

    FYI ‘Default setting for new posts’ for AMP and IA are both set to Enable for Posts and Pages.

    https://wordpress.org/plugins/pagefrog/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The same to me

    I’m having the same issue. Every time I edit a post, the enable AMP toggles off.

    Plugin Author pagefrog

    (@pagefrog)

    Hi pwcom, newzdotit, cdgeog,

    We just pushed out an update on our plugin that should fix all issues around Enabling AMP on all posts and pages! Let me know if it works for you.

    Have been running the new v1.0.8 code since Friday – I’m pleased to report that it’s fixed the issue.

    Thank you!
    (Case closed)

    Plugin Author pagefrog

    (@pagefrog)

    Great to hear! Thanks for letting me know, powcom 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.