Support » Fixing WordPress » have to press Ctrl F5 to show am logged in

  • Hi, I have a unique issue that i find impossible to fix.

    [ Moderator note: moved to Fixing WordPress. ]

    When I login to my WordPress site (www.apis-iq.com, it’s a customer built site so no updates like with e.g. twenty-fifteen) and then click on the front end: sometimes it shows me as logged out and doesn’t display the dashboard. If I press Ctrl + F5 it shows the dashboard again.
    As this happens irregularly (but very often), i cannot simply deactivate each of the 20 plugins to see which is causing the issue as i may remain logged in and may not.
    My question:
    Have you any suggestions other than deactivating plugins to see what is wrong with the website? Do you know of this ever happening?
    My main issue is that when a user logs into the forum, it sometimes shows that they are logged out even though they are not.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi @haddlyapis,

    Do you have any plugins relating to caching (e.g. Total cache)?

    Would you mind confirming if the error still occurs if you clear the cache of your browser and if you are using a caching plugin clear that as well?

    If that does not resolve the issue, try switching to the default theme for your version of WordPress to rule-out a theme-specific issue (theme functions can interfere like plugins).

    I hope the OP doesn’t mind me adding to this thread, but to the question “Do you know of this ever happening?” I can say that I have a similar problem which started minutes after my installation was auto-updated to 4.7.4

    When logged into the back-end all is fine, I go from there to the front-end using the link in the menu-bar, and the front-end comes up and displays me as logged out. Pressing F5 reloads it as logged out, pressing Ctrl+F5 reloads it as logged in, another F5 shows logged out etc. etc..

    It’s a strange thing that I’ve not seen before in over a decade of WP blogging.

    I disabled all of the 59 plugins which I have installed and which were working fine without conflicts, but the problem was still there so I don’t think it’s a plugin problem. Clearing the cache made no difference.

    I consulted my host’s help staff, they downgraded me to 4.7.3 but it has not fixed the issue (although it has fixed all other problems I was having with 4.7.4).

    It’s got me baffled. Perhaps it needs a database table rebuild?

    http://beardedgit.com

    • This reply was modified 2 years, 4 months ago by  beardedgit. Reason: Edit: added URL
    • This reply was modified 2 years, 4 months ago by  beardedgit.

    Hello,
    I have a similar problem.

    My site is http://www.soccer-betbrain.com . Everything has been working perfectly for at least 10 months. Now when I log in, I don’t see my login details. If I press CNTL F5 the page refreshes, and the login details can be seen.

    My feeling is that wordpress 4.7.4 is screwing things up. This has really damaged my site. Have no idea how to fix this …

    Any help appreciated,

    Neil.

    I am going to try and rollback my version of wordpress and see what happens. Will follow this tutorial https://www.youtube.com/watch?v=_lX3E-qIpJM and will keep you posted.

    The tutorial works but the rewind of wordpress (i went back to version 3.9.18) did not solve my problem

    still have a delayed cache problem only resolved by CNTL F5

    @neilovan:

    FWIW, when I click the link to your site, I’m seeing the following:

    Warning: require(/home3/toklosh/public_html/soccer-betbrain.com/wp-includes/version.php): failed to open stream: No such file or directory in /home3/toklosh/public_html/soccer-betbrain.com/wp-settings.php on line 29
    
    Fatal error: require(): Failed opening required '/home3/toklosh/public_html/soccer-betbrain.com/wp-includes/version.php' (include_path='.:/opt/php54/lib/php') in /home3/toklosh/public_html/soccer-betbrain.com/wp-settings.php on line 29

    Not sure what that means, but it doesn’t look good.

    I think if you press CNTL F5 the error goes away. Never had anything like this since witching to wordpress 10 months ago.

    its not a browser problem because im trying modzilla, IE and chrome on 3 different devices.

    • This reply was modified 2 years, 4 months ago by  neilovan.
    • This reply was modified 2 years, 4 months ago by  neilovan.

    I had tried Ctrl+F5 before I reported the error here but it made no difference to me, probably because I don’t have a login there.

    Anyway, it’s not throwing the error now, it loaded OK and I can see your message there regarding the problem.

    Sadly, nobody seems to want to jump on this problem. If I hear of a fix I’ll let you know via this support thread. Good luck!

    Ah it goes from bad to worse. Cannot access my wp-admin at all now. What a ‘^^%^$^A distaster

    Well finally have a solution to this problem.
    For some reason my CPU usage went over 25% or my processes went over 25 concurrent and hostgator decided to disable the caching for my account.

    Fair enough, it is a shared account. But surely YOU HAVE TO NOTIFY YOUR CUSTOMERS that you are doing this. They wasted 2 days of my effort, 2 restores from backups and huge aggravation, which was totally unnecessary.

    I had the exact same issue. Had to hit ctrl + F5 for the login to take affect.

    I solved the issue by contacting my host, in this case bluehost, and ask them to purge/disable their server side cache for my domain. In fact, I’m not entirely sure if they disabled it or just purged it, but the goods news is that all the login issues I was having were solved!

    So, contact your host and tell them to purge/disable the cache for the domain in question.

    The host activates the cache automatically when a peak performance is reached. So, if you experienced some heavy CPU processing as of lately, this may have caused you to be cached.

    Hope this helps.

    Mine has sorted itself out… sort of…

    I had the “recent posts” Jetpack widget showing post thumbs in the sidebar, I had an inkling that it might be caching the post thumbs so I removed the widget.

    Straight away it went screwy, with “bad gateway” errors when trying to load front-end or back-end. After clearing the caches and rebooting, it was no better, so I decided to let it be and get a good night’s sleep before asking the host to fix the bad gateway thing.

    And this morning, before contacting the host, I booted up, went to the back-end, and logged in straight away with no probs. Going from there to the front-end also worked, I’ve been shown as logged in all day, no need for the Ctrl+F5, no need to get the host involved at all (unless they found the bad gateway thing themselves and fixed it while I was asleep).

    Whatever it was, it’s gone now.

    Hopefully the OP’s site has been fixed too.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘have to press Ctrl F5 to show am logged in’ is closed to new replies.