WordPress.org

Forums

WP to Twitter
[resolved] Have to manually update post for tweet?? (12 posts)

  1. Dykarna
    Member
    Posted 1 year ago #

    When there is a post or job postings then it should work with the plugin "WP Job Manager" on my page so do not send the tweet. I may go in and manually check the "Tweet this post". and then press "update" for it to be sent to my twitter.

    It is when you do a front page posting ie. not as admin

    What am I missing and where then?

    https://wordpress.org/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    The way that WP Job Manager handles front-end posts requires you to configure WP to Twitter to enable Tweeting of edited posts in order to Tweet them.

    To prevent WP to Twitter from automatically Tweeting all edits, you should check the advanced setting "Do not post Tweets by default (editing only)".

  3. Dykarna
    Member
    Posted 1 year ago #

    I have 3 fields and the only one that is checked is
    "Do not post Tweets by default (editing only)"

  4. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Yes. That's correct. And you also have to have Tweeting of edits enabled in basic settings.

  5. Dykarna
    Member
    Posted 1 year ago #

    Both in "post" and "Job listning" if you talking about "status update template"

  6. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Doesn't matter for Post, but yes, I'm talking about the status update template. You also need to ensure that the role that is posting from the front-end has permission to Tweet.

  7. Dykarna
    Member
    Posted 1 year ago #

    I dont know whats wrong...

    I have in "settings / general" New User Default Role: Employer
    Same I got in Job submission in Jobmanager, Account Role: Employer

    I still have to manual update tweet.

  8. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    And in WP to Twitter settings, does the Employer role have permission to Tweet?

    Know that custom roles, like Employer, aren't hierarchical like the default roles, so the permissions have to be assigned directly to the role.

  9. Dykarna
    Member
    Posted 1 year ago #

    Under Permissions I have

    Admin
    Admin
    Admin
    Employer (The lowest user group that can send Twitter updates)

    Do I miss something?

  10. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Try unchecking the option "Do not post Tweets by default (editing only)" -- it may be that your job postings are being picked up as edits, and still being blocked by that option.

  11. Dykarna
    Member
    Posted 1 year ago #

    Looks like it works now :-D

  12. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Great. Thanks for updating.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP to Twitter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.