Support » Plugin: Co-Authors Plus » Have to enable Unsafe-eval in CSP to enable admin post/metabox functionality

  • I am trying to set up CSP on my multisite blog. The co-author widget/ metabox in the post window does not work unless I set scripts to allow ‘unsafe-eval’ in my CSP.

    Only the “Click on an author to change them. Drag to change their order. Click on Remove to remove them.” shows up. (no search box appears and you cannot select /drag and drop authors)

    This is my csp:
    Header set Content-Security-Policy “default-src https:; script-src https: ‘unsafe-inline’ ; style-src https: ‘unsafe-inline’; img-src * ; font-src * ; object-src ‘none’ ;”

    I could override the css hiding this (#coauthors-edit .hide-if-no-js) to unhide it and but is less than ideal. I am new to csp and my have it configured incorrectly….

    Any help would be greatly appreciated.

  • The topic ‘Have to enable Unsafe-eval in CSP to enable admin post/metabox functionality’ is closed to new replies.