Support » Themes and Templates » Have timthumb working but..

Have timthumb working but..

  • I installed timthumb and its working fine yet I cant figure out where to put the actually thumb in the code. I tried placing the timthumb call code before and after the title and many other places. I am trying to make it so the thumbnail is on the left side of the title and post description. Instead it is either under or over it.

    Code I am using to call timthumb:

    <?php // This will show the image and link the image to the post. Alter the width and height (in both places) to your needs. ?>
    		<?php if ( get_post_meta($post->ID, 'thumb', true) ) { ?>
    	<div class="postthumb">
    		<a href="<?php the_permalink(); ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><img src="<?php bloginfo('template_directory'); ?>/scripts/timthumb.php?src=<?php echo get_post_meta($post->ID, "thumb", $single = true); ?>&h=150&w=150&zc=1" alt="<?php the_title(); ?>" width="150" height="150" /></a>
    <?php } ?>

    Code I am using in my index template file:

    <h3><a href="<?php the_permalink() ?>" rel="bookmark"><?php the_title(); ?></a></h3>
    <?php the_excerpt(); ?>
    <div class="details">
    						<?php the_time('F j, Y'); ?> | <?php comments_popup_link(__('Leave comment'), __('1 Comment'), __('% Comments'));?> | Topic <?php the_category(', ') ?> | <a href="<?php echo get_permalink(); ?>" title="Read More">Read More</a>

Viewing 5 replies - 1 through 5 (of 5 total)
  • anyone help please?

    well it varies depend on design of your blog

    you can try above `<?php the_excerpt(); ?>

    Ya I tried above and below the excerpt is there a way to combine it inside the <?php the_excerpt(); ?> as everything else doesnt work

    you can design the look using css file, as i mentioned already it’s depend on theme how it’s design

    hitboy so sorry i forgot about the excerpt well thumbnail will not show if you have excerpt you have to replace with content tag check default theme or codex page

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Have timthumb working but..’ is closed to new replies.