WordPress.org

Support

Support » Installation » Have I deleted my site trying to upgrade to 3.4?

Have I deleted my site trying to upgrade to 3.4?

  • foodrambler
    Member

    @foodrambler

    Hi there,

    I tried to upgrade my blog foodrambler.co.uk automatically to 3.4 by pressing the automatic upgrade button and now receive this message when trying to access the site & the dashboard:

    Warning: require(E:\domains\f\foodrambler.co.uk\user\htdocs/wp-includes/option.php) [function.require]: failed to open stream: No such file or directory in E:\domains\f\foodrambler.co.uk\user\htdocs\wp-includes\functions.php on line 8

    I realise now that it was very silly to try & upgrade without reading the upgrade notes. I’ve looked through them now at http://codex.wordpress.org/Upgrading_WordPress_Extended

    I think I did step 1 (I clicked export and have an .xml wordpress file in my downloads folder that I am hoping is my back up) but unfortunately not steps 2, 3 or 4

    Any help would be brilliant.

    Many thanks,
    Abi

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi
    Forum Moderator

    @esmi

    What version of WordPress were you running?

    foodrambler
    Member

    @foodrambler

    I don’t know – how do I check?

    esmi
    Forum Moderator

    @esmi

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – running the upgrade manually via wp-admin/upgrade.php

    Are you using Windows hosting (Microsoft-IIS/6.0)?

    foodrambler
    Member

    @foodrambler

    Thanks Esmi. Sorry to be dense, but I’m not sure where my wp-content folder would be. Would it be inside PhpMyAdmin?

    Krishna, I’m using a Mac
    Thanks,
    Abi

    foodrambler
    Member

    @foodrambler

    Okay, I’ve found my /htdocs/wp-content/themes folder – which folder inside there do I rename? There are the following folders:
    up
    atahualpa
    classic
    default
    paper
    tarski
    index.php

    Or is it the whole themes folder that I rename?
    Thanks,
    Abi

    esmi
    Forum Moderator

    @esmi

    What was the name of the theme that you were using?

    foodrambler
    Member

    @foodrambler

    I think it was tarski

    esmi
    Forum Moderator

    @esmi

    Try renaming the tarski folder to tarski-old.

    foodrambler
    Member

    @foodrambler

    Hi esmi,

    I’ve renamed the tarski folder to old, but I can’t do the next stage – resetting the plugins folder by FTP or phpMyAdmin – because my options folder has disappeared:

    Warning: require(E:\domains\f\foodrambler.co.uk\user\htdocs/wp-includes/option.php) [function.require]: failed to open stream: No such file or directory in E:\domains\f\foodrambler.co.uk\user\htdocs\wp-includes\functions.php on line 8

    Thanks,
    Abi

    esmi
    Forum Moderator

    @esmi

    Please re-read my post above. None of the suggestions I made require you to login to your WordPress dashboard.

    Oncilla
    Member

    @oncilla

    I just did the automatic upgrade to 3.4 and now all my links are gone off the site. How do I get them back. There is only the main page now.

    http://savannahcatsrus.com/

    The links were across the dark bar. The link should be the same as this similiar site of mine.

    http://bengalcatsrus.com/

    Gary

    RichardWPG
    Member

    @richardwpg

    @oncilla, please create a new post. Thanks

    Oncilla
    Member

    @oncilla

    @richardwpg, It’s all good now. I fighured out the issue. I had to register the menu within wordpress and then call it within the template files.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Have I deleted my site trying to upgrade to 3.4?’ is closed to new replies.