WordPress.org

Forums

hatom-entry warnings for Google authorship (7 posts)

  1. rutterj
    Member
    Posted 2 years ago #

    I hope this is the right place to post since I'm unsure of what the problem is I didn't know where to go.

    So, I've tried using multiple SEO and Google authorship plugins, right now I'm sticking with the basic seo pack and authorsure. Google rich snippets says everything is in order except some hatomentry warnings, and the authorship does not show up in Google searches.

    These are the warnings:
    hatom-feed
    hatom-entry:
    Warning: At least one field must be set for HatomEntry.
    Warning: Missing required field "entry-title".
    Warning: Missing required field "updated".
    Warning: Missing required hCard "author".

    Warning: At least one field must be set for HatomEntry.
    Warning: Missing required field "entry-title".
    Warning: Missing required field "updated".
    Warning: Missing required hCard "author"

    I followed suggestions that lead me to authorsure which didn't fix it (tried both the footnote and menu options). I saw suggestions to go into the single.php file and change some tags. Except the issue is this is all that's in my single.php file:

    <?php
    	global $SMTheme;
    
    	get_header(); 
    
    	get_template_part('theloop');
    
    	the_tags("<div class='tags'><span>".$SMTheme->_( 'tags' ).":  </span>", ", ","</div>");
    
    	get_template_part('relatedposts');
    
    	comments_template();
    
    	get_template_part('navigation');
    
    	get_footer();
    
    ?>

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

    I tried pasting in h1 entry title entry tags anyway, but that didn't do anything except make individual posts unable to open.

    I'm using the Architecture theme by SMthemes, which I assume might be part of the problem if the single.php file is so bare.

    http://mcelherne.com/

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    I'm sorry but your chosen theme is not released under GPL. Non GPL products are not welcome in the WordPress community. Official WordPress policy states that all plugins and themes that are publicly released are required to adhere to http://wordpress.org/about/gpl/

    I would also strongly recommend that you read this article and consider changing to a theme from a reputable source asap.

  3. rutterj
    Member
    Posted 2 years ago #

    Ok, so if we ignore the parts about my poor choice of theme, is there a way to fix the hatomentry warnings?

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Try posting in the dedicated support forum for your Google plugin(s).

  5. rutterj
    Member
    Posted 2 years ago #

    Thank you :)

  6. ianarmstrong
    Member
    Posted 2 years ago #

    Uh, wow...

    For those who get here via Google:
    http://blog.no-panic.at/2006/11/16/hatom-and-wordpress/

  7. Fivera
    Member
    Posted 1 year ago #

    Hi, I've solved all my problems and errors using this method

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.