WordPress.org

Support

Support » Themes and Templates » HATCH theme: trouble with static HOME page

HATCH theme: trouble with static HOME page

  • coyotesuit
    Member

    @coyotesuit

    Hi all.

    I’m building my site through the Hatch 0.1.7 theme by Galin Simeonov, and I’m trying to have my home page open into a static page with one embedded ‘full width’ templated video, but the video (hosted w/ Vimeo) comes out as a tiny, strangely-formatted thumbnail, resembling a tiny post thumbnail.

    I don’t know if this is a bug in the theme, but I think I’ve followed the instructions precisely, creating new home page, a new blog page, and then pointing the new home page and pointing posts to the blog page, through Settings->Reading.. (Btw, I don’t have any pages named “home” and I’m not having any problems with navigation for this new static home page- which seem to be the only category of problems that turn up when researching this issue)

    I’ve tried all sorts of troubleshooting, leaving my new “home” page off the menu scheme, leaving the template on default, etc. but no matter what the content or configuration, I always end up with the these tiny bizarre thumbnail versions of an embedded video. (which, despite not showing any vimeo playbar overlays, will play if clicked on)

    I haven’t messed with the php templates (obviously not a developer), but in earlier stages of building my site, I REMOVED the content in the COMMENTS php template.. (I couldn’t figure out how to disable comments through the various dashboard options). This gave me results in terms of getting rid of the embedded comment areas on each page, but now I wonder if this template was integral somehow to some of the functionality. Everything works fine on the site, but I can’t seem to get this static page ironed out.

    Any input greatly appreciated.

    Thanks, Matt

Viewing 15 replies - 1 through 15 (of 25 total)
  • I am having the same problem. It looks like it is reverting to some tiny thumbnail layout even though the full-width is selected for the page i have listed as “Front Page” under reading settings.
    Very confusing…
    my site is at haleywcreative.com

    The theme isn’t built to use a static page as home page. There is no mention of such thing in the documentation. I guess you are confusing it with one of my other themes – Oxygen.

    Of course it’s possible to modify it to display static pages on the index in a visually appealing way, but it would require some custom work.

    Shannonannkeenan
    Member

    @shannonannkeenan

    does anyone have any experience with creating a working static homepage with the hatch theme? it is so beautiful, i really do not want to find another to work with.

    i am a noobie, so not every experienced with coding, but i am going to try to mess around with the index and see if i can get somewhere.

    ultimately i want a slide show and a blurb about my art on the homepage…

    i truly appreciate anyone’s shared experience and solutions with this static homepage issue.. it seems like quite a few people have tried to make it work..
    my site is shannonannkeenan.com.

    thanks!

    I’m experiencing the same problem too. I can’t insert a large image centered on the home page. Please can someone look into this and help us out. Many thanks
    Drake

    avadhut.deshmukh
    Member

    @avadhutdeshmukh

    HATCH theme Apologies, but no entries were found.??????plz reply

    Not sure what you mean about ‘No entries were found”?
    I can’t get a large picture on the first page /Static page using the Hatch Theme. (which I love BTW) it only gives me a small thumb nail on the far left side.
    Any help would be appreciated.

    avadhut.deshmukh
    Member

    @avadhutdeshmukh

    http://www.electronicsrobot.tk/ look

    what No entries were found ?????

    Sorry I’m not stupid but your link did work once and I saw a graphic on the right hand side which look like it was in the Hatch theme. Are you trying to tell me you can place a image on the home page in hatch? if so can you explain how you got it work.

    I can´t find where to place the text to the right for the big main picture on the mainpage….

    I have found a solution for placing images in the 4 bottom content areas that are posts but having those posts go to pages.
    You have to install the plugin “Quick Page/Post Redirect DEV” and then you can assign 4 posts to those areas (with images), but redirect each to a different Page, so that the visitor never actually views the content of the post, but goes straight to the page. This allows you to feature images on the homepage but link to pages that hold your actual content.

    As far as featuring text to the left of the main page image, that is edited by going to Users -> Your Profile and editing the BIO for yourself. That bio is what displays on the homepage. The page is found at http://www.yoursite.com/wp-admin/profile.php (yoursite replaced with your URL of course).

    I have implemented the post/page redirect plugin on my site at http://www.haleywcreative.com and it works great.

    Hello,
    I´m having trouble to insert the first page text. I can´t get it…

    Any help please??

    Tanks

    san_sa_rocky
    Member

    @san_sa_rocky

    i need to change the header link to one of my static page.. but cannot find which line to edit in header.php
    help please

    site is farhanamarzia.com

    Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    @san_sa_rocky, please create your own thread with your own details.

    randominality
    Member

    @randominality

    Hello all, after trying to figure out how to achieve this on my own site for a few hours I figured it out.
    You need to edit style.css and replace

    .home .hentry, .archive .hentry {
    	float: left;
    	width: 23.40425531914894%;
    	height: 150px;
    	margin: 0 2.127659574468085% 20px 0;
    	position: relative;
    	overflow: hidden;
    }

    with

    .home .hentry {
    	float: left;
    	width: 100%;
    	margin: 0 0 20px 0;
    	font-size: 1em;
    }
    .archive .hentry {
    	float: left;
    	width: 23.40425531914894%;
    	height: 150px;
    	margin: 0 2.127659574468085% 20px 0;
    	position: relative;
    	overflow: hidden;
    }

    And then in the wordpress reading settings page change the frontpage to be the static page you want.

    san_sa_rocky
    Member

    @san_sa_rocky

    my problem is solved.. 😀

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘HATCH theme: trouble with static HOME page’ is closed to new replies.