Support » Fixing WordPress » hashcash and firefox/blank wp-comments-post.php page

  • I have hashcash installed to help control spam comments. It works fine in internet explorer. In firefox I get a blank wp-comments-post.php page. This is indicative of not having javascript active (from reading another post). I installed sun’s JRE 1.4_2_7. When I do an about:plugins it shows me Java Plug-In enabled. I’ve tried uninstalling and reinstalling firefox. Nothing seems to work. Also, same from Netscape 7.2

    Stuck. any ideas appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Not the Java plugin, but javascript. They are completely different!

    Any idea how I can fix the problem?

    So when you uninstall hashcash it works? Did you grab the latest release? See I have Java Runtime installed, I have Wp-Hashcash, and four installs of WP 1.5 with hashcash, as well as running FF 1.01 and it works perfectly fine.

    Did you manually install Hashscash by hacking away at the code or did you grab the file upload and just activate it? Are you saying viewing the page gives you a blank page? It seesm to display for me.

    Check that JavaScript[1] is enabled in FireFox:

    Tools menu, Options
    Select “Web Features”
    Look at the tickboxes.

    [1] It would have been so much simpler if JavaScript had been given a different name, wouldn’t it?

    Probably not the same problem if it’s working in IE, but I had a devil of a time getting hashcash going until I realized that I’d saved the .js and .php files incorrectly, with gobs of whitespace and spaces replaced with & nbsp; tags. Fixed those and then it worked a treat.

    Get the latest here:

    http://dev.wp-plugins.org/browser/wp-hashcash/trunk/

    Use the download link at the bottom of the page.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘hashcash and firefox/blank wp-comments-post.php page’ is closed to new replies.