The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] hash symbol problem in links (3 posts)

  1. kmardahl
    Posted 9 years ago #


    I wanted to add a link to someone's website in my post. The link has a jump so the entire URL includes a hash symbol. WP kept erasing everything between the href=" and the slash+hash symbol. The erased stuff was the true domain, and when I viewed it on an active web page, my domain was inserted! I tried editing via the rich text editor and directly in the html code. Nothing. The correct domain kept disappearing. I use utf-8 encoding on my site.

    Support had 4 entries concerning the hash symbol, which didn't really help. There was one bug issue at http://trac.wordpress.org/ticket/2385.
    It seems as thought this Tiny MCE (http://sourceforge.net/projects/tinymce/) should solve my problem, but it seems like an awful lot of work for this issue. I mean, a link is a link, and shouldn't anything be permitted between the double quotes in the link?

    I was able to add the correct link in a comment to my own post.

    You can see the link in question at:

  2. Chris_K
    Posted 9 years ago #

    If you disable the WYSIWYG editor (Users -> Your Profile, top checkbox uncheck) does the problem still happen when you add the link?

  3. kmardahl
    Posted 9 years ago #

    Thanks, HandySolo, but a friend pointed out another solution before I saw yours. There was a slash in front of the hash symbol. When I pasted in the link with the slash, everything in front of the slash disappeared. When I removed the slash, everything remained as it should. The link worked. The slash is on the site I link to, but a hyperlink without still works.
    I'll try disabling the WYSIWYG another time. Thanks for that tip. I will most likely need to keep it in mind!

Topic Closed

This topic has been closed to new replies.

About this Topic