WordPress.org

Support

Support » Reviews » Has Potential, but Doesn't work

Has Potential, but Doesn't work

  • jamiechong
    Participant

    @jamiechong

    I hope I’m the only one experiencing this problem:

    I’ve added new custom meta (globally), but then it doesn’t show up in the user profile. The keys that I create also don’t show up in the “Edit Custom Meta”, but they do in the “Delete Custom Meta”

    What’s going on?

Viewing 3 replies - 1 through 3 (of 3 total)
  • jamiechong
    Participant

    @jamiechong

    I am getting this PHP Warning when I view a user’s profile page.

    PHP Warning: Illegal offset type in isset or empty in /path-to/wp-content/plugins/user-meta-manager/user-meta-manager.php on line 917

    jamiechong
    Participant

    @jamiechong

    I found your issues:

    You’re using the foreach loop improperly here:

    Line: 456:
    foreach($sort_order as $profile_field_name):

    You expect the key, but this is giving you the value. Use this instead:
    foreach($sort_order as $profile_field_name => $sortValue):

    Similarly you have the same problem here:

    Line: 916:
    foreach($sort_order as $profile_field_name):

    You probably have the same issue elsewhere, but these immediately stood out to me.

    Plugin Author President McCheese
    Member

    @jason-lau

    Please report bugs in the support section and not in the reviews section. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Has Potential, but Doesn't work’ is closed to new replies.