Support » Plugin: Pricing Deals for WooCommerce » Has Anyone Got it Working Right?

  • Resolved SolutionsDEV

    (@solutionsdev)


    It does have many features, so it need a lot of time to know how it is going to work, but finally I got something working even though that it is not what I want.

    The most important problem is that I got products listed in the cart page and below it the discount details, but just beneath it the cart totals which does not show the discount in the totals and when going to the checkout page it also does not show any discounts.

    Any solutions to this?

    What I am aiming is that a real BOGO “but one get one free” but it needs to be listed clearly. Any help in doing that?

    Thanks,

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author vark

    (@vark)

    Hi,
    Thanks for using the plugin.

    Support is always available both in this forum and in my website support channel:
    https://www.varktech.com/support/

    That being said, I’d like to confirm the issues you’re reporting…

    1. you’re having an issue creating a ‘buy 1 get 1 free rule’
    – if so, an example is here:
    https://wordpress.org/plugins/pricing-deals-for-woocommerce
    FAQ Section
    “Buy 1 get next 1 at a Discount”

    2. you’re having a discount display issue
    – is the discount not carrying through to the totals, or is it that you’d like to have a separate broken-out amount in the totals currently not being shown ?

    Best,
    Vark

    SolutionsDEV

    (@solutionsdev)

    @vark in the cart totals which is by woocommerce nothing showing related to the discount and it shows the full amount without discounts, the checkout page also shows the total amount without discounts.

    I will look for the faq as suggested.

    Also thank you for the quick response.

    Plugin Author vark

    (@vark)

    Hi,
    No worries.

    If the discount is not carrying through to the totals,
    You likely have a memory, caching or module conflict issue.

    (A) Set your memory to a minimum of **512mb** , the de-facto memory standard (or greater!)
    (** Double-check ** the following, even if already set to 512mb.)
    (*) Memory should be *explicitly* set in *both* the php.ini (host) file,
    and in the wp-config.php file .
    – call your HOST to **Confirm or Set** the explicit setting of 512mb of memory in php.ini
    – update your wp-config.php file with a statement like this: define(‘WP_MEMORY_LIMIT’, ‘512M’);

    (B) Caching:

    Do you have a caching plugin (W3 Total Cache, etc)
    – If so, please **clear the caching plugin cache**. Test. **Turn off caching**. Test.
    – If that isn’t it, carry on…
    (Pricing Deals is happy, however, with ** WP Super Cache: by Automattic ** , which seems to keep up better )

    (C) if that’s not it , suggest a *full module conflict test*:

    To track down a module conflict, please follow these steps ** PRECISELY **:
    (1) Install and activate a maintenance mode plugin (if desired)
    (2) Then, DO ALL (*at the same time*):
    (-) do a full site backup!
    (-) deactivate ***all*** plugins except Woo, my plugin (and maintenance mode plugin)
    (-) ** switch to a clean default theme like 2019 **
    — (This removes all other possible conflicts.)
    (-) turn off all deals except the one we are examining.

    (3) ** test **
    (4) if good, add 1 module back in. ** Retest **
    (5) Repeat until conflict identified.

    ** This test depends on following the outlined steps fully. **

    Best,
    Vark

    (PS – If you do have a module conflict, it will likely boil down to choosing between the 2 conflicting modules…)

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.