Support » Plugin: WP/LR Sync Folders with Real Media Library » Hangs on sync, always at same media and collection

  • I’ve tried resetting and resyncing numerous times. I found instructions on going back to old version of WP/LR to try to clean things up, and that didn’t work. It seems there ought to be some sort of “start from scratch” switch.

    Possible confounding things: I’m on a multisite, but that hasnt been a problem before. I’ve turned off caching so that’s an unlikely culprit. I’ve spent hours on this – any ideas?

    As I said, I’d be happy to go back to square one – it would be a lot of work, but if I knew it would work I’d do it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Jordy Meow

    (@tigroumeow)

    Hi @joefryfoto!

    As you know, I am not the developer behind WP/LR Sync Folders, but I would like to make sure of something since your issue concerns the Sync.

    Can you check your PHP Error Logs and share what you find?

    Also, does the sync works if you disable this plugin?

    Thread Starter joefryfoto

    (@joefryfoto)

    Hey Jordy, thanks for the quick response. I’ve managed to slog thru most of the damage by doing the following:

    Say the problem is in LR collection “bridges.” I create a new collection “new bridges” and publish all my images to it.
    Then I publish to WP. Then I delete all “bridges” images and publish the deletions. Then I delete the “bridges” collection folder.

    Then…

    I go to WordPress and run the folder sync.
    Then it stops somewhere else! I identify the collection and repeat the whole process!
    It took about four iterations, but is working.

    I don’t know whether sync worked with WP/LR Sync Folders disabled.
    I do know that it consistently stopped at the same image/collection each time it hung.

    I know just enough to be dangerous. Do I have to enable PHP error log and then catch it in the act?

    Let me know anything helpful in that process.

    And thanks for the great software – it’s been a godsend – I’m looking forward to the next-phase, using WP/LR Theme Assistant to help automate the structure and hierarchies.

    Plugin Contributor Jordy Meow

    (@tigroumeow)

    I don’t know whether sync worked with WP/LR Sync Folders disabled.

    Please give it a try 🙂 That will be useful to know where the bug is actually happening. Right now, there are three plugins involves (because that works with RML). If you disable this plugin, then it only WP/LR Sync. For me, it’s important to know since I am taking care of that one (and I wouldn’t want any bug in the core).

    I know just enough to be dangerous. Do I have to enable PHP error log and then catch it in the act?

    Absolutely. In fact, you should always check the PHP Error Logs when you have issues (and from time to time even if you don’t): https://meowapps.com/debugging-wordpress/. Without it, nobody will be able to help when there is an issue with your website. Please do and report what you see 🙂

    Plugin Author Matthias Günter

    (@mguenter)

    Hi @joefryfoto!

    Thanks @tigroumeow for already having a look at this support ticket. As Jordy already mentioned, can you please try to deactivate “WP/LR Sync Folders” and check if the sync works as expected? We just want to make sure all is right with the WP/LR sync itself.

    Best regards,
    Matthew 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hangs on sync, always at same media and collection’ is closed to new replies.