Support » Plugin: WordPress Importer » Hangs on import – will not import

  • Exported from old blog fine.

    New blog (WordPress 3.7.1) will not import the 1.4MB file. Just hangs and does nothing after five minutes, I clicked on dashboard and the process evidentially cancelled.

    Tried again:
    I manually created the same user who authored original posts with “Author” privileges in case that is what was hanging it and still not luck. I do not get anything after clicking “Upload file and import” no options to assign author or anything, it just hangs and goes no further.

    Does anyone have some suggestions as to what I might try next?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Tried exporting all data and still no luck with importing into WP 3.7.1. On previous attempt, I only exported posts.

    Could be that the export is coming from an older version of WordPress (3.0.?) which unfortunately cannot be updated due to it still needing to remain online and the high chance that it will likely break when updating.

    I will be trying this plugin next to see if I have any better luck with it.

    WP All Import:

    Any other thoughts?

    Ok, so here is my update.

    1. Could not update the existing Blog due to concerns of it breaking with such a drastic jump in versions and it needs to be online still for now. So, I downloaded all files including database and set it up on my other server. All went well, except for having to use bigDump to split the database as it was too large even though after zipping it was smaller than the max 50MB size.

    Updated WordPress to the new version although version 3.8 was just released and with auto update that was my only choice. So now running version 3.8 with the old Blog, works fine. Exported all content using WordPress built in exporter. Tried to import into new site and it hangs just as before.

    2. Tried exporting only posts, hoping a smaller file size will be better, and it also hangs on import just as before.

    3. Tried using phpMyAdmin to import individual tables and did not have any luck with this option as well.

    Wondering if manually entering all blog post content is going to be easier than trying to get it to import? I am really concerned about needing to reenter all the comments etc. Getting pretty disappointed at this point.

    I will donate to any developer who can get a working importer doing what is suppose to do. Wish I had the programming chops to pull it off myself. Hint: there is money to be made here.

    Urrrrgh! WordPress, please get this working!!

    Not ideal but a way that worked for me was to run the import about 7 times.

    Good Luck

    This is old, but I had a similar problem importing content. After a minute or two it would just hang, and also part of the page would disappear (although the sidebar and some other parts would remain). Tried it several times and kept on getting the same problem. I eventually found out if I keep the page open for a while after it starts to hang that the import continues in the background, even though it looks like it stopped, I just had to make sure I keep the page open, don’t refresh, click on any links, etc., and let it run. I could browse the blog in another tab to see if the imported content was showing up. I also changed the max_execution_time in my php.ini file, although that didn’t seem to get rid of the hang.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hangs on import – will not import’ is closed to new replies.