Support » Fixing WordPress » Hanging when accessing, editing and trying to open Posts

  • Hello Gurus,

    I am in a bit of a quandary, I have been working on an odd issue for a couple of days and hope someone out there has seen this and knows a fix.

    The main issue is that when accessing the Post administration panel inside the dashboard, the site hangs and tries to load, but doesn’t complete. I can see all the posts listed but the very last post in the list does not show all the information (like tags). Also if I try to open a post it will hang and only show a little of the admin screen, no content and some of the WIZYWIG is missing, if it shows at all. All the while it is still trying to load. Lastly, if I try to move a post out of trash it errors out.

    The whole dashboard and other admin screen are very slow, but still seem to function.

    Without being able to modify, add, edit posts the site is pretty much useless, so I am looking for help!

    —What is working—
    1. The site is still working from a user standpoint, rendering of the pages/posts and other content does not seem to be affected.
    2. Other admin panels, like pages, plugins, etc.

    –What I have tried – without success–
    1. Cleaned all local browser cache and tried multiple browsers
    2. Disabled all plugins and removed “old” deactivated ones.
    3. Increased memory in php.ini to 32MB
    4. Increased memory in wp-config to 256MB (tried lower as well).
    5. Turned off WP-Supercache, cleared host cache and re-enabled.
    6. A ton of Google searches looking for the magic fix.

    –A little about the site–
    1. URL:
    2. WP: 3.4.2
    3. Plugins: (all-in-one-seo, wp-super cache, google-xml-sitemaps, addthis, polldaddy, MailChimp, OptionTree (runs the theme), WP-DBManager, Ad Injection, Ad Squares Widget, Akismet, LDB External links, YARRP, NextGen Gallery)
    4. Total posts/pages: 170ish
    5. I use GoDaddy for hosting and have another site on the same setup and it is working properly.

    I appreciate the help!


Viewing 4 replies - 1 through 4 (of 4 total)
  • It is really hard to debug remotely but it sounds like a timeout or a memory problem. 32MB is WordPress’s official minimum. You may need more than than, but 256MB is way too much. If your site needs that much or more you’ve got serious structural problems. Since you have messed with the memory already, check PHP execution time. Look for max_execution_time and maybe push it up to a minute or so (from 30 to 60) and see if that helps.

    Yes, we realize that 256MB is far too large, it was just a troubleshooting tactic and it has been set back to 64MB.

    We will take a look at the max_execution_time as recommended and report back.

    In the meantime we are also looking to rebuild our wp-config manually as it did not seem to get updated with the re-install.

    One thing worries me: I have run WordPress on very cheap servers and the execution time has never been an issue for the basic admin screens. If that is the problem, your server would seem to be very slow or very overloaded.

    In the meantime we are also looking to rebuild our wp-config manually as it did not seem to get updated with the re-install.

    It wouldn’t be rebuilt on update. As far as I am aware it never is, and I’ve never known a need to rebuild it. You may want to add a thing or two here and there but a rebuild is probably not necessary.

    Sorry it took so long to report back… It has been a heck of time figuring this out. We have isolated it to some issue around Tiny MCE, we don’t know what exactly but that is what is causing us to hang.

    As a work around we have removed the visual editor from our profile but that causes problems for the not so tech savvy content writers.

    We turned on debugging for Firefox and Chrome, when we switch between visual and html editor modes, we get 2 Javascript error. They are:

    1. switchEditors is not defined
    2. tinyMCE is not defined

    We don’t know where something went wrong, to the best of our knowledge we did not manipulate this.

    As part of our troubleshooting we also deleted the wp-admin and wp-includes and rebuilt from a fresh install file. This didn’t help either.

    All the support posts we see about this are years old and don’t seem to apply to current versions (3.4.2)

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hanging when accessing, editing and trying to open Posts’ is closed to new replies.