Support » Fixing WordPress » Hanging on Database Update Required

  • Resolved OliverC

    (@oliverc)


    Hello Everyone,

    I could really use some help/advice here. I run the following blog:
    http://www.wiretotheear.com/

    I did the automatic upgrade to 3.5 and although the site is still online when I try and log in via wp-admin I get the following message:

    “Database Update Required WordPress has been updated! Before we send you on your way, we have to update your database to the newest version. The update process may take a little while, so please be patient.”

    When I click “Update WordPress Database” I just get a blank screen with the WordPress logo on top… it never completes anything.

    I’m a novice at the backend of the this stuff. So far I tried increased my PHP memory to 128MB but it has not fixed the issue.

    Any advice would be really appreciated!

    – Oliver

Viewing 15 replies - 16 through 30 (of 42 total)
  • esmi

    (@esmi)


    Forum Moderator


    Try:
    – switching to the Twenty Twelve theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    – running the upgrade manually via wp-admin/upgrade.php

    Hi Esmi,

    I did everything exactly step by step and again stuck on the white screen with the WordPress logo like this:
    http://www.flickr.com/photos/thingstocomerecords/8288415428/in/photostream

    Please keep giving me advice. What can I try next?

    esmi

    (@esmi)


    Forum Moderator


    Now try repairing the database using Phpmyadmin or whatever database management application that your host provides.

    Hi Esmi,

    I repaired the database using PHPMyadmin as you can see. After I tried to upgrade wordpress again and it didn’t work. I’m stuck on the white screen with logo.

    Screenshot of PHPMyadmin after the repair:
    http://www.flickr.com/photos/thingstocomerecords/8288518922/in/photostream

    What should I try next? Thanks.

    esmi

    (@esmi)


    Forum Moderator


    Create a fresh database, restore your backup to it, upload a fresh copy of the WordPress 3.4.2 core files & folders (except for the wp-content folder) and amend your wp-config.php file to point at this new database.

    Hi Esmi,

    I will take your advice. Before I start I tried it one more time and interestingly now I received this error:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in /home/wiretoth/public_html/wp-includes/wp-db.php on line 1220

    Strange that error never popped up before. Does this clue us in to what may be going wrong?

    esmi

    (@esmi)


    Forum Moderator


    Hi Esmi,

    I increased the memory and now I get this error:

    Fatal error: Maximum execution time of 60 seconds exceeded in /home/wiretoth/public_html/wp-includes/wp-db.php on line 1219

    What do you think? Should I “Create a fresh database, restore your backup to it, upload a fresh copy of the WordPress 3.4.2 core files & folders (except for the wp-content folder) and amend your wp-config.php file to point at this new database.” or something else now?

    Thank you!!

    esmi

    (@esmi)


    Forum Moderator


    First try asking your hosts if they can temporarily raise the max_execution_time on your site to allow to you to push this upgrade through.

    Raising the max_execution_time didn’t help. I create a fresh database and am restoring my back up to it. I have 15 .sql files uploading each under 50MB using myPHPadmin. There is also an index.php file… do you know if I need to upload that?

    (This part will take some time.. uploading is a bit slow)

    esmi

    (@esmi)


    Forum Moderator


    You don’t need to upload the index.php file that came with your backups.

    Ok well I think the problem has something to do with wp_options. When upload I received this error: http://www.flickr.com/photos/thingstocomerecords/8288496009/in/photostream

    Error
    
    SQL query:
    
    INSERT INTO <code>wp_options</code>
    VALUES ( 246, 0, 'vks_ad_flex_niche_content_link_color', '3C657B', 'yes' ) ;
    
    MySQL said: Documentation
    #1062 - Duplicate entry '246' for key 1

    Any ideas? Oh my!

    esmi

    (@esmi)


    Forum Moderator


    That looks like a problem caused by a plugin or possibly a previous theme. That line/record definitely isn’t needed by WordPress itself.

    I’m uploading the other files now. How does the backup work? Even though there was en error did that file upload?

    esmi

    (@esmi)


    Forum Moderator


    No. The .sql import would have stopped at that error.

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘Hanging on Database Update Required’ is closed to new replies.