WordPress.org

Forums

hanged after theme activation (9 posts)

  1. pikkabbu
    Member
    Posted 8 years ago #

    I installed tiga-06 theme, and it seems that it has a bug.
    Now, I can't enter any more as administrator, so I can't change this theme.

    Any way to go ahead ?

    This is the error message I get when I want to enter as administrator.

    Fatal error: Call to undefined function: add_theme_page() in /home/admin2/public_html/blog/wp-content/themes/tiga-06/themetoolkit.php on line 84

    tks in advance

    pik

  2. Austin Matzko
    Member
    Posted 8 years ago #

    Use your FTP or SSH program to change the theme's directory name from tiga-06 to something like Ignore_tiga-06. Then WordPress will no longer see it when looking for the active theme, and it will load the default theme instead.

  3. pikkabbu
    Member
    Posted 8 years ago #

    Thank you, but... it doesn't work.

    I get nothing but a blank page (code shows nothing between body tags).

    I tryed to rename default as tiga-06 with ftp (and not any theme named tiga-06 in the carpet), and that allows me to see the front page. But it hags with same error code when I try to identiy as admin.

    I feel puzzled to get the same error code than using tiga-06....
    Fatal error: Call to undefined function: add_theme_page() in /home/admin2/public_html/blog/wp-content/themes/tiga-06/functions.php on line 129
    as the only tiga-06 theme in the carpet is the default renamed.

    Someone can help ?

    tks in advance

  4. yosemite
    Member
    Posted 8 years ago #

    Try deleting the whole tiga directory?

  5. vkaryl
    Member
    Posted 8 years ago #

    I think it doesn't matter what you rename the folder to, the theme info is read from the css file comments. So deleting the folder is the only way to get back to the default (and be sure you have the default folder actually in the themes folder! Been there done that one....)

  6. pikkabbu
    Member
    Posted 8 years ago #

    tks again, still doesn't work.
    I delete tiga-06 from the themes folder,
    default is present

    but all I get is a blank page.

    :-(

    No way.
    Fortunatly, I only had trial stuff onto WP, but I can't imagine what could happen with valuable one. Can't stay with such a strange behaviour blog, I'll delete WP from serveur and use dotclear.

    Thank to you 3 for the help-

    pik

  7. Austin Matzko
    Member
    Posted 8 years ago #

    I think it doesn't matter what you rename the folder to, the theme info is read from the css file comments.

    Actually just renaming the directory will change the theme setting. Try it if you don't believe me.

    Sounds like there's another problem--perhaps an errant plugin?

  8. rainbowgrl
    Member
    Posted 8 years ago #

    hey, i just installed my own theme , but seem to be getting an syntax error with my theme or something.

    Parse error: syntax error, unexpected T_STRING in /home/yvwcignu/public_html/wp-content/themes/falloutboyv1/header.php on line 78

    if anyone could tell me how to fix this problem it would be great

    -serena

  9. Austin Matzko
    Member
    Posted 8 years ago #

    rainbowgrl, I'm guessing you left off a closing parenthesis or something like that in your header.php.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags