Support » Plugin: Wordfence Security - Firewall & Malware Scan » Had Falcon enabled – Update to 6.2.1 – Unable to access to switch off / uninstal

  • Resolved shinerweb

    (@shinerweb)


    Just updated to 6.2.1 and I had the Falcon engine enabled on a site using the free WordFence option. (It’s a test site which is a complete mirror of a production site).

    I see no notice of the impending removal of Falcon, but the “Performance Setup” option has been remvoed from the sidebar menu.
    I now have no way to disable or revert the Falcon engine settings.
    I can still see the “Clear Cache” button in the top WP menu bar, but on clicking this, the front dashboard is reloaded.

    Any clues?
    I’ll hang off reverting to the previous version for a few hours until I see any response from you guys.

Viewing 14 replies - 16 through 29 (of 29 total)
  • @ sorin_gheorghita,

    Did you read my post about the older version?
    Seems you have 2.6.1. and trying to revert back to the same version??

    The older version is 2.6.0. and unfortunately I no longer have that one.
    I did not have to revert back, just manually deactivated falcon.
    In case errors accur, best thing to do seems to be deleting wordfence all together and
    re-install a fresh one.

    Plugin Author WFSupport

    (@wfsupport)

    As of Wordfence version 6.2.1, we are removing support for Falcon. This wasn’t a decision we made lightly. We discussed it internally for a while before we finally decided to remove it. We have released a statement about it on our blog:

    https://www.wordfence.com/blog/2016/10/removing-falcon-cache-wordfence-heres-need-know/

    The bottom line is that we’re focusing our energies on security, which we are very good at. If you need a recommendation for a caching solution, there is a great post at this link comparing caching plugins:

    https://www.designbombs.com/top-wordpress-caching-plugins-compared/

    Users that didn’t have Falcon enabled should no longer see “Performance Setup” in the wordfence menu on their sites. Users who came into the update with Falcon enabled should see it. Defining the constant WF_ENABLE_FALCON in your wp-config.php file will cause it to be shown no matter if it was or was not enabled prior to the update.

    We have no plans to release this part of the plugin to the community at large as a separate plugin.

    As always, thanks for your support and for using Wordfence.

    • This reply was modified 4 years, 9 months ago by WFSupport.

    @logologics I read your post, yes. I have the version 6.2 and I was trying to revert to 6.1.

    @wfsupport I didn’t use this plugin, but today a news client asked me to make some changes on the website (Css stuff) and I can’t clear the cache. So there is no solution for those who had the cache option enabled? They will be suck forever with the website as it was in the moment of the update?

    At least, please give us a solution to manually delete all the cache elements form the website, so the changes of the website will be visible.

    Thank you!

    Hi there,

    Not sure about your 6.2. version. the most recent one is 6.2.1 and the one before that was 6.2.0.
    If you where trying to revert to actually 6.1. that might give errors because it’s more then one version prior to the one you have at that time.

    However, staff have been answering and this might help you:

    Users that didn’t have Falcon enabled should no longer see “Performance Setup” in the wordfence menu on their sites.

    Users who came into the update with Falcon enabled should see it.

    Defining the constant WF_ENABLE_FALCON in your wp-config.php file will cause it to be shown no matter if it was or was not enabled prior to the update.

    You can find their answer in this post: https://wordpress.org/support/topic/no-more-falcon-engine-nooooooooooo/#post-8284872

    Good luck!

    • This reply was modified 4 years, 9 months ago by LogoLogics.

    Hi sorin,
    you should still be seeing the “Performance” section in Wordfence if you have Cache enabled. We have tested this extensively but in your case it would appear there is some detail we were not aware of.

    Sorin, please add this to wp-config to forcefully enable Falcon: define(WF_ENABLE_FALCON, ‘true’);

    For anyone reading this later please note that adding this constant will not work when cache is finally removed. So do not use it to keep the feature because then you will get big issues when caching is completely removed.

    • This reply was modified 4 years, 9 months ago by wfasa.
    Thread Starter shinerweb

    (@shinerweb)

    @wfsupport / @wfasa

    Users that didn’t have Falcon enabled should no longer see “Performance Setup” in the wordfence menu on their sites. Users who came into the update with Falcon enabled should see it. Defining the constant WF_ENABLE_FALCON in your wp-config.php file will cause it to be shown no matter if it was or was not enabled prior to the update.

    My original post stated that even though I had Falcon enabled prior to updating to 6.2.1, caching was still enabled and I didn’t receive the “removal notice”.

    I did use your define(WF_ENABLE_FALCON, ‘true’); suggestion which allowed me to disable Falcon caching, clear down the cache.
    There is a still a “Delete Cache” option in the top Admin bar which is broken, but only a minor issue.

    Even after removal of the WF_ENABLE_FALCON #define, the “Delete Cache” option is still visible.
    Might be an idea to remove that menu option completely given that (a) the cache feature is disabled/to be removed and (b) it’s a broken link that doesn’t do anything other than possibly confuse the end user.

    Hi shinerweb,
    Wordfence Falcon cache does not have this “Clear Cache” or “Delete Cache” link in the top admin bar.
    I know that “WP Super Cache” plugin has “Delete Cache” link in the admin bar, also “Comet Cache” plugin has “Clear Cache” link in the same bar, maybe you have any of these plugins installed?

    Try to disable Wordfence plugin -temporarily- and I’m pretty sure you will get the same “Delete/Clear Cache” link in admin bar.

    Thanks.

    Thread Starter shinerweb

    (@shinerweb)

    ah, “holds hands up” time… being my offline test server, I had somehow managed to enable both WP Super Cache (the source of the Clear Cache button as you correctly pointed out) and had the Falcon Cache enabled.
    It might have been the WP Super Cache confusing Falcon as not being enabled.
    I did use the WF_ENABLE_FALCON #define which allowed me to switch off Falcon engine. Just didn’t spot I had WP Cache enabled as well.
    Shouldn’t update in the mornings prior to coffee…
    apologies for the extra hassle.

    btw. Totally agree with your decision to remove the Falcon from WordFence. Best security plugin out there, why muddy the waters with extra bells and whistles. Sometimes it’s not a good idea to be a Jack of all trades, master of none.

    So if I had caching on when performance Setup was removed from the settings, does that mean it is still on and cannot be now turned off?

    I wish there was more information about this

    I am sorry I can’t give more information. My problem was that my client was using another caching system o the server. If you disable the plugin, the cache should be disabled too, if the caching is based only on this plugin.

    Hi @voodoochill,
    If you had Falcon Cache enabled on your website, then you still should see “Performance Setup” in the menu, if for any reason you can’t see it, please check this reply by Asa.

    P.S. that’s the code you need to copy define(WF_ENABLE_FALCON, 'true'); I’ve just corrected the single quotes around true.

    Thanks.

    • This reply was modified 4 years, 9 months ago by wfalaa.

    Thanks wfalaa

    In my case the Performance Setup was not removed on updading, however if I clicked on it I just got an error saying something along the lines of “You do not have permission to view this”

    Then after I used the browser back button, the Performance page was gone.

    However using the code above in wp-config.php restored the page and I was able to then turn off the falcon.

    Do I need to remove the wfcache folder?

    This folder can be removed, but there is no need to do that in your situation.

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘Had Falcon enabled – Update to 6.2.1 – Unable to access to switch off / uninstal’ is closed to new replies.