Support » Plugin: Taxonomy Thumbnail » [hacky] Categories enabled for Pages, thumnail column doesn't show

  • Unexpected behavior, not a bug but i’d like to try to work it out.

    I’m using the following functions to enable the use of post categories for pages:

    // add category support to pages
    function categories_support_all() {
      register_taxonomy_for_object_type( 'category', 'page' );
    }
    
    // ensure all tags and categories are included in queries
    function categories_support_query( $wp_query ) {
      if ( $wp_query->get( 'category_name' ) ) $wp_query->set( 'post_type', 'any' );
    }

    This works generally. However, after activating this plugin, if I access the category edit screen from the Pages -> Categories admin submenu (rather than the usual way, from the Posts submenu), I don’t get a thumbnail upload column, even though in the “Screen Options” dropdown at the top, the “Thumbnail” column is available and checked.

    The thumbnail box does show from Posts -> Categories, the usual way. It also shows on the main Page -> Categories list / “Create new Category” column, so I know the plugin is hooking into this screen in some ways.

    I should just say it’s throwing no php errors or javascript errors. I tried disabling all other plugins and switching to default theme. Also I’m not using the filter to disable the term thumbnail anywhere.

    https://wordpress.org/plugins/sf-taxonomy-thumbnail/

  • The topic ‘[hacky] Categories enabled for Pages, thumnail column doesn't show’ is closed to new replies.