WordPress.org

Forums

[resolved] h1 tag issue (10 posts)

  1. Anam
    Member
    Posted 2 years ago #

    Hi,

    Please see my site http://seentrust.org.uk/.
    Issue: I have a h1 tag <h1>seen2help - we provide a wide range of Outsourced Business Serviecs</h1>
    But I would like to change this to <h1>Seen Trust - Bringing the UK Military and Small Business Communities Together.</h1>

    My current source code are:

    <!--/container--></div><div class="container">
    <img src="http://seentrust.org.uk/wp-content/themes/seencic/img/slide.png" id="main-image">
    <!--/container--></div>
    <div id="blue-bg">
    <div class="container">
    <h1>Seen Trust - Bringing the UK Military and Small Business Communities Together.</h1>
    <!--/container--></div>

    For some reason My h1 is not changing it to the one i would like to see despite the source showing it.

    Please can someone help me on it?

    Thank you

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Where are you trying to change it?

    It looks like that may be generated from a template or other theme setting? In which case, you need to find where it's pulling that text from.

    What theme is that?

  3. Anam
    Member
    Posted 2 years ago #

    Thanks,

    It is a personalised theme by my previous designing company.

    Regards

  4. Anam
    Member
    Posted 2 years ago #

    Found nowhere, searched everywhere. Do you know any possible location where i could locate it?

    Regards,

  5. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Perhaps it's hard coded into the template for that page? Or a theme option? Really no way for anyone to know on a custom theme.

  6. Anam
    Member
    Posted 2 years ago #

    Hi,

    Does below make any sense, found it under header.php

    <hgroup>
    				<h1 id="site-title"><a>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a></h1>
    			</hgroup>

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

    Thanks

  7. WPyogi
    Forum Moderator
    Posted 2 years ago #

    No, that's actually a header title - it's not visible because CSS has moved it off the page because you are using the logo in the header.

    But I just looked again and found it! This CSS (line 3106) is doing something weird there:

    #blue-bg h1 {
        background: url("img/h1.png") no-repeat scroll 0 0 transparent;
        height: 27px;
        margin: 130px auto;
        text-indent: -9999px;
        width: 940px;
    }

    Change that to:

    #blue-bg h1 {
        height: 27px;
        margin: 130px auto;
        width: 940px;
        color: white;
    }

    Fix the font size or whatever as you like.

  8. Anam
    Member
    Posted 2 years ago #

    Hi,

    Thanks for your help that's a big relief. For some reason the font size is not affecting. do i have to change in stylesheet.css or in homepage.php?

    Regards,

  9. WPyogi
    Forum Moderator
    Posted 2 years ago #

    This seems to work - too big obviously :) so change as you like:

    #blue-bg h1 {
        color: white;
        font-size: 50px;
        height: 27px;
        margin: 130px auto;
        width: 940px;
    }
  10. Anam
    Member
    Posted 2 years ago #

    Hi,
    Thanks a lot. I appreciate your help.
    Regards

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags