• Resolved elizoliva

    (@elizoliva)


    I have looked through the many other threads on Gzip issues in this forum, but nothing suggested has made any difference for me.

    I am running Apache webserver with PHP-FPM 7.0. I have the mod_deflate enabled, and in my php.ini I have:
    zlib.output_compression = On

    When I click on ‘Re-check Status’ I still get:

    Gzip is not working properly:

    – Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
    – Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.
    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

    Here are the contents of my .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    <IfModule mod_deflate.c>
        SetOutputFilter DEFLATE
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    </IfModule>

    Is there anything else I should try?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author calumbrash

    (@calumbrash)

    Hi @elizoliva,

    Could you please provide us with the URL for the site you’re having issues with so we can debug this further?

    Cheers,
    Calum

    Thread Starter elizoliva

    (@elizoliva)

    ifpte20.org

    Plugin Author calumbrash

    (@calumbrash)

    Hi @elizoliva,

    I’ve checked manually and it looks like your site is running GZIP fine. Are you using the latest version of Hummingbird? In the version previously to the current one, Hummingbird was having issues detecting GZIP for some sites.

    Cheers,
    Calum

    Thread Starter elizoliva

    (@elizoliva)

    I am using the latest version of Hummingbird, yes.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @elizoliva,

    It looks like you have Nginx server and need to apply rules to the Nginx configuration. Adding the custom rules to the .htaccess file will not make gzip compression for CSS and JS files work. Could you please try applying rules from the Nginx section?

    Best regards,
    Anton

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @elizoliva

    Hope all is well!

    We’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Kind regards,
    Nastia

    Alexandra A.

    (@montenegroecoadventuresorg)

    Hi Nastia!
    I have exactly the same issue on 2 of my sites:
    http://www.znuggle.me
    http://www.spondeotravel.com
    I ue latest version of Humming Bird, and everything is up to date on my site.
    I don’t know if I have an Nginx server though?
    What do I need to do?
    How can I be ‘applying rules’ and how?
    Thanks tons! Alexandra

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @montenegroecoadventuresorg

    Ask your host which type of server you’re running on and then you can go to Hummingbird > GZIP Compression panel, select your server type and switch to Manual tab where you will see instructions on how apply the rules.

    If you need further assistance with this please start new ticket and we will look into this further for you.

    Cheers,
    Predrag

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Gzip not working’ is closed to new replies.