Support » Plugin: Hummingbird Page Speed Optimization » Gzip is not working properly:

  • Resolved djole74

    (@djole74)



    This is massage:

    Gzip is not working properly:

    – Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
    – Another plugin may be interfering with the configuration

    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

    ——————————-
    Just HTML is Disabled
    ——————————-
    Server cloudteh™ Solutions answer:
    Hi,

    Our engineers confirmed that mod_deflate 2.4.27-8.8.1.cpanel has already been installed on our cPanel server.

    Another plugin may be interfering with the configuration – It seems like this point is the issue you’re experiencing. Something in your website CMS is interfering with your actions.
    ——————————-
    htaccess:
    ——————————-
    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    <IfModule mod_setenvif.c>
    # Netscape 4.x has some problems…
    BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    # BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
    # the above regex won’t work. You can use the following
    # workaround to get the desired effect:
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

    # Don’t compress images
    SetEnvIfNoCase Request_URI .(?:gif|jpe?g|png)$ no-gzip dont-vary
    </IfModule>

    <IfModule mod_headers.c>
    # Make sure proxies don’t deliver the wrong content
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    </IfModule>
    ———————————
    I tried to manually change it but after that it was the same.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @djole74,

    Try removing this part from the .htaccess file:

    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    <IfModule mod_setenvif.c>
    # Netscape 4.x has some problems…
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    
    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    
    # MSIE masquerades as Netscape, but it is fine
    # BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    
    # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
    # the above regex won’t work. You can use the following
    # workaround to get the desired effect:
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    
    # Don’t compress images
    SetEnvIfNoCase Request_URI .(?:gif|jpe?g|png)$ no-gzip dont-vary
    </IfModule>

    And enable gzip from Hummingbird. After you enable it, press on ‘re-check status’ button.

    Best regards,
    Anton

    djole74

    (@djole74)

    Internal Server Error

    site crash
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@allforyourpets.com to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Sorry, my mistake, didn’t see an extra if statement. Just for the sake of the test, remove the whole block that you posted from the .htaccess file and try rechecking the status from the plugin and applying automatic settings.

    Best regards,
    Anton

    djole74

    (@djole74)

    Now the htaccess is empty and I still get HTML Disabled.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    This is what I have in my .htaccess file from Hummingbird:

    # BEGIN WP-HUMMINGBIRD-GZIP
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>
    # END WP-HUMMINGBIRD-GZIP

    Could you try pasting this in?

    djole74

    (@djole74)

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @djole74,

    Strange. What is your Apache version?

    djole74

    (@djole74)

    Server Information
    Item Detail
    Hosting Package cPanelSSD2
    Server Name cloudweb
    cPanel Version 66.0 (build 24)
    Apache Version 2.4.27
    PHP Version 5.6.31
    MySQL Version 10.0.32-MariaDB
    Architecture x86_64
    Operating System linux
    Shared IP Address 144.217.30.144
    Path to Sendmail /usr/sbin/sendmail
    Path to Perl /usr/bin/perl
    Perl Version 5.16.3
    Kernel Version 2.6.32-042stab120.11

    Plugin Author Anton Vanyukov

    (@vanyukov)

    And if you remove absolutely everything from .htaccess file and re-check the status from Hummingbird, will you see the same settings? Or will JavaScript and CSS be disabled? I’m just trying to understand what’s blocking the settings from the .htaccess file.

    djole74

    (@djole74)

    Same, only HTML disabled.
    On cPanel I have Optimize Website.
    http://prntscr.com/gvna3v
    I tried all the combinations.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Just for testing purposes I recommend you disable cPanel optimization for now. We need to find what’s blocking the .htaccess file. Sometimes it can be the server configuration or a plugin conflict. I’m assuming you don’t have any more optimization plugins installed and enabled. Let’s try one last test:

    1. Disable cPanel optimization (if not already).
    2. Empty the .htaccess file. Go to Hummingbird and re-check the gzip status. If nothing changes, go to the next step.
    3. Enable automatic configuration for Apache server in Hummingbird. Verify that all the rules have been added to the .htaccess file. Once again click on ‘re-check status’ button.

    If you don’t see any changes, that means your .htaccess file is ignored by Apache. You should ask your hosting support if they have AllowOverride All directive set for your site. If it’s not set, no mater what you put in your .htaccess file, it’s not going to be applied.

    djole74

    (@djole74)

    I’ve tried all the suggested steps but nothing.
    Hosting support answer this:
    cloudteh™ Solutions

    Hi,

    We do allow overrides on our cPanel server and .htaccess file is applied.

    djole74

    (@djole74)

    Current Theme

    HuemanVersion: 3.3.21
    By nikeo

    This plugin is used:

    AliDropship Woo Plugin
    Facebook for WooCommerce
    Hueman Addons
    Hummingbird
    Jetpack by WordPress.com
    MailChimp for WooCommerce
    WooCommerce Cart
    Woo Total Sales
    WooCommerce Extended Coupon Features
    WooCommerce PayPal Express Checkout Gateway
    WooCommerce Google Analytics Integration
    Woocommerce with the active version of WooCommerce
    WooCommerce Shortcodes
    WooCommerce
    Yoast SEO
    WP Redis
    WP Smush

    This error is in log file:

    2017-10-12T15:15:41+00:00 CRITICAL Uncaught Error: Call to undefined function submit_button() in /home/ehhgphot/public_html/wp-admin/includes/file.php:1287
    Stack trace:
    #0 /home/ehhgphot/public_html/wp-content/plugins/hummingbird-performance/core/class-filesystem.php(156): request_filesystem_credentials(‘https://allfory…’, ‘ftpext’, false, false, Array)
    #1 /home/ehhgphot/public_html/wp-content/plugins/hummingbird-performance/core/class-filesystem.php(89): WP_Hummingbird_Filesystem->init_fs()
    #2 /home/ehhgphot/public_html/wp-content/plugins/hummingbird-performance/core/class-filesystem.php(119): WP_Hummingbird_Filesystem->__construct(‘gravatar’)
    #3 /home/ehhgphot/public_html/wp-content/plugins/hummingbird-performance/core/modules/class-module-gravatar.php(33): WP_Hummingbird_Filesystem::instance(‘gravatar’)
    #4 /home/ehhgphot/public_html/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php(27): WP_Hummingbird_Module_Gravatar->init()
    #5 /home/ehhgphot/public_html/wp-content/plugins/hummingbird-performance/core/class-core.ph

    Plugin Author Anton Vanyukov

    (@vanyukov)

    This error is not related to gzip, it’s going to be fixed in the next version.

    Let’s test if .htaccess is working.

    The simple solution to verify and check if the .htacess configuration file is even touched and parsed is forcing an error. More precisely a 500 Internal Server Error.

    In order to do that you simple add something to the first line of the config file that doesn’t make any sense. This could be a single letter or number, a word, basically anything that is not a directive.

    If you get the 500 Internal Server Error you know that the file has been read because that line triggered the error.

    If you don’t get an error your server setup is wrong because your .htaccess has not even been touched.

    djole74

    (@djole74)

    I got 500 Internal Server Error.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Gzip is not working properly:’ is closed to new replies.