• Resolved michaeleasycount

    (@michaeleasycount)


    Hi,

    Second time this plugin has just stopped working overnight.

    GZIP won’t work for HTML as I’m in Privacy Mode? What is that?

    Also, another error;

    “- Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).”

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Anton Vanyukov

    (@vanyukov)

    @michaeleasycount,

    Gzip detection does not work in privacy mode. There should be a warning regarding this in the module, after you click “Re-check status” button.

    Best regards,
    Anton

    michaeleasycount

    (@michaeleasycount)

    I have done this Anton, I don’t even know what Privacy Mode is, or where to find it.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @michaeleasycount,

    I’m a bit confused – do you have Privacy Mode enabled or not? If not, are you seeing a notice about Privacy Mode in the Gzip module?

    Best regards,
    Anton

    michaeleasycount

    (@michaeleasycount)

    Anton, I’ve said three times, what is Privacy Mode?

    And yes, I mentioned in the earlier post I’m seeing a notice about Privacy Mode.

    If by Privacy Mode, you mean Incognito on the browser, then no, I’m not in that.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @michaeleasycount,

    Privacy Mode will be shown when Hummingbird is getting a “401 Unauthorized” response when checking the status of Gzip compression. This is often caused by various blocks: password protection, firewalls, misconfigured security plugins. If you have any of the above, please try to disable the features/plugins to test if that fixes the issue.

    Best regards,
    Anton

    michaeleasycount

    (@michaeleasycount)

    Okay but how do I check that I’m in Privacy Mode? The notice says I am, but this isn’t the first time Hummingbird has given me incorrect messages (see previous support tickets).

    Nothing has been changed or updated on the website over the weekend so I’m surprised this has happened.

    Password protection on where Anton, sorry? My WordPress?

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @michaeleasycount,

    You should ask your host why fetching local files returns “401 Unauthorized” response. Unfortunately, I don’t have access to your server logs, so cannot tell you the reason why this is happening. I can confirm that Gzip compression is not enabled for HTML on your site. But, again, this should be addressed to your host. You should ask why the rules from .htaccess are not applied to enable gzip compression for your site.

    Best regards,
    Anton

    michaeleasycount

    (@michaeleasycount)

    They’ve said that Mod Deflate is active & working.

    The .htaccess file is also being written to and from correctly. As I said, this has been working fine before, infact for a long, long time there has been no issue apart from over the weekend (nobody touches the website during that time).

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @michaeleasycount,

    Hummingbird is just reporting the status that is set. Unfortunately, there’s no way for HB to modify server configuration. Maximum it can do is modify the .htaccess file to try and activate it. But a lot depends on the server configuration. If your host is saying that gzip is enabled, they should provide a working .htaccess rule to enable it on the site, otherwise it is not enabled, and it can be verified by any external gzip check tool.

    Best regards,
    Anton

    michaeleasycount

    (@michaeleasycount)

    Okay Anton, thanks a lot for your help.

    I’ll prompt them about the .htaccess rule.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Welcome. If your host provides you with a working set of rules for .htaccess, please post them here, so we can add support for your host in future updates.

    Best regards,
    Anton

    michaeleasycount

    (@michaeleasycount)

    Hey Anton,

    Just giving you an update, apparently the fix had to be done in our cPanel.

    For future reference, a fix for others might be the same as mine, which was;

    Enabling zlib.output_compression in MultiPHP INI Editor through cPanel.

    Now the Gzip is working – tested this by running it through external Gzip checkers, content-encoding and through Hummingbird.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @michaeleasycount,

    Thanks for sharing the information.

    Best regards,
    Anton

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘GZIP Disabled – AGAIN’ is closed to new replies.