Support » Plugin: Hummingbird – Speed Up WordPress » Gzip compression not working

  • Resolved rafatfe

    (@rafatfe)


    The plugin said me this:

    Gzip is not working properly:

    – Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
    – Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.

    My hosting is in 1and1 and Gzip is enabled

    Can you help me please ?

    Regards
    Rafael

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @rafatfe

    Hope you’re doing well!

    Please, add the following line to the php.ini file on your server:
    zlib.output_compression = On
    If php.ini doesn’t exist, feel free to create it. After this line is added, re-check the status from Hummingbird > GZIP Compression

    Please clarify for which types (HTML/CSS/JS) the GZIP is deactivated. I’ve checked your site with checkgzipcompression.com and GZIP is enabled on your site. It is possible that your server’s firewall blocking Hummingbird from checking if GZIP is enabled.

    Let us know how it went!

    Cheers,
    Nastia

    Hello Nastia, I put ” zlib.output_compression = On ” in the file php.ini and not work

    any idea more ?

    Pd. My hosting is 1and1

    sorry, is active for HTML but inactive for javascript and css

    Plugin Support Oguz – WPMU DEV Support

    (@wpmudev-support8)

    Hey @rafatfe,

    Hope you’re well.

    At the thread, while saying “Gzip Enabled”, you mean enabled by Hummingbird or your hosting? Do you know is your server running on Apache or Nginx? And did you try to put provided codes from Hummingbird to your server configuration?

    If you are not comfortable about editing Apache .htaccess or Nginx conf, you can ask your hosting provider to edit for you.

    Cheers,
    Oguz

    can you check please ?

    deagapornis.com/info.php

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @rafatfe

    Hope you’re doing well!

    Your server is running on Apache. Please make sure the following rules are added into the .htaccess file

    <IfModule mod_deflate.c>
    	SetOutputFilter DEFLATE
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    </IfModule>

    The mod_deflate may actually not be enabled. please apply rules shared in this article too.
    https://help.1and1.com/hosting-c37630/scripts-and-programming-languages-c85099/htaccess-c37776/enable-gzip-compression-moddeflate-a792767.html

    Let us know how it went!

    Cheers,
    Nastia

    Nastia not working

    In plugin ” system information ” said this:

    Use this info if you are having issues with Hummingbird and your server setup. It will give you the most up to date information about your stack.
    
    PHP
    Version	7.0.30
    max_execution_time	30
    open_basedir	
    memory_limit	268435456
    upload_max_filesize	67108864
    post_max_size	67108864
    display_errors	1
    log_errors	0
    track_errors	0
    session.auto_start	0
    session.cache_expire	180
    session.cache_limiter	nocache
    session.cookie_domain	
    session.cookie_httponly	
    session.cookie_lifetime	0
    session.cookie_path	/
    session.cookie_secure	
    session.gc_divisor	100
    session.gc_maxlifetime	1440
    session.gc_probability	1
    session.referer_check	
    session.save_handler	files
    session.save_path	
    session.serialize_handler	php
    session.use_cookies	1
    session.use_only_cookies	1
    Error Reporting	E_ERROR
    E_WARNING
    E_PARSE
    E_CORE_ERROR
    E_CORE_WARNING
    E_COMPILE_ERROR
    E_USER_ERROR
    E_USER_WARNING
    E_RECOVERABLE_ERROR
    E_ALL
    Extensions	bcmath
    bz2
    calendar
    cgi-fcgi
    Core
    ctype
    curl
    date
    dba
    dom
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    hash
    iconv
    imap
    intl
    json
    libxml
    mbstring
    mcrypt
    mysqli
    mysqlnd
    openssl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Phar
    posix
    Reflection
    session
    shmop
    SimpleXML
    soap
    SPL
    sqlite3
    standard
    tidy
    tokenizer
    wddx
    xml
    xmlreader
    xmlwriter
    xsl
    zip
    zlib
    

    and this is my .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    <IfModule mod_deflate.c>
    	SetOutputFilter DEFLATE
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    </IfModule>
    

    the plugin for html working fine, but CSS and Javascript is INACTIVE

    any idea ?

    Hi, Nastia, I have the exact same issues as above and tried all your recommended changes, including the php.ini addition. No help. All html, css and js are not being compressed. I re-checked, cleared the cache, deactivated this auto compression and re-activated it twice. Still not working.
    I am using an Apache server and the host has this code to put in .htaccess in addition to the gZip compression from Hummingbird which is active in my file:

    AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript

    After doing this, still the same. Your next recommendation, please?
    Chris

    Plugin Support Oguz – WPMU DEV Support

    (@wpmudev-support8)

    Hey @rafatfe,

    Hope you’re well.

    Did you try the link Nastia shared with you for 1and1 hosting? Your hosting company already explain the necessary actions for Gzip Compression so please try https://help.1and1.com/hosting-c37630/scripts-and-programming-languages-c85099/htaccess-c37776/enable-gzip-compression-moddeflate-a792767.html this guide too.

    You can remove the old .htaccess code that shared by Nastia and try on the guide, also you can try these codes together too. If still not helps, please ask advice from your hosting why the deflate rules not applied to server.

    Cheers,
    Oguz

    Plugin Support Oguz – WPMU DEV Support

    (@wpmudev-support8)

    Hey @ysmr,

    Hope you’re well.

    I can’t check your website because of you didn’t share any link yet but if you tried all recommendations and all necessary codes are on your htaccess or nginx configuration file, but still can’t solve; can you contact with your hosting provider to ask is deflate enabled for your hosting? If yes why not apply the rules on configuration files. Also, according to WordPress.org forum guides, you need to create a new thread;

    Unless users have the exact same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme, and configurations, then the odds are the solution for one user will not be the same for another. For this reason, we recommend people start their own topics.

    (https://make.wordpress.org/support/handbook/forum-welcome/#post-in-the-best-place)

    So if the problem continues please open a new thread for your issue.

    Cheers,
    Oguz

    Thanks, Oguz,
    I did talk to GoDaddy about the Apache deflate module and they asked me to put this in the HTML together with the Gzip script from Hummingbird:

    AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript

    My site is http://www.Unboundedlife.com as well as http://www.ginkgosociety.org (same issue on GoDaddy Apache server) and my .htaccess is as follows:

    RewriteOptions inherit
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css application/x-javascript application/javascript
    # END WordPress

    # BEGIN WP-HUMMINGBIRD-GZIP
    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    <IfModule mod_setenvif.c>
    <IfModule mod_headers.c>
    SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
    RequestHeader append Accept-Encoding “gzip,deflate” env=HAVE_Accept-Encoding
    </IfModule>
    </IfModule>
    <IfModule mod_filter.c>
    AddOutputFilterByType DEFLATE “application/atom+xml” \
    “application/javascript” \
    “application/json” \
    “application/ld+json” \
    “application/manifest+json” \
    “application/rdf+xml” \
    “application/rss+xml” \
    “application/schema+json” \
    “application/vnd.geo+json” \
    “application/vnd.ms-fontobject” \
    “application/x-font-ttf” \
    “application/x-font-opentype” \
    “application/x-font-truetype” \
    “application/x-javascript” \
    “application/x-web-app-manifest+json” \
    “application/xhtml+xml” \
    “application/xml” \
    “font/eot” \
    “font/opentype” \
    “font/otf” \
    “image/bmp” \
    “image/svg+xml” \
    “image/vnd.microsoft.icon” \
    “image/x-icon” \
    “text/cache-manifest” \
    “text/css” \
    “text/html” \
    “text/javascript” \
    “text/plain” \
    “text/vcard” \
    “text/vnd.rim.location.xloc” \
    “text/vtt” \
    “text/x-component” \
    “text/x-cross-domain-policy” \
    “text/xml”

    </IfModule>
    <IfModule mod_mime.c>
    AddEncoding gzip svgz
    </IfModule>
    </IfModule>
    # END WP-HUMMINGBIRD-GZIP
    # BEGIN WP-HUMMINGBIRD-CACHING
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A0

    <FilesMatch “\.(txt|xml|js)$”>
    ExpiresDefault A691200
    </FilesMatch>

    <FilesMatch “\.(css)$”>
    ExpiresDefault A691200
    </FilesMatch>

    <FilesMatch “\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$”>
    ExpiresDefault A691200
    </FilesMatch>

    <FilesMatch “\.(jpg|jpeg|png|gif|swf|webp)$”>
    ExpiresDefault A691200
    </FilesMatch>
    </IfModule>

    <IfModule mod_headers.c>
    <FilesMatch “\.(txt|xml|js)$”>
    Header set Cache-Control “max-age=691200”
    </FilesMatch>

    <FilesMatch “\.(css)$”>
    Header set Cache-Control “max-age=691200”
    </FilesMatch>

    <FilesMatch “\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$”>
    Header set Cache-Control “max-age=691200”
    </FilesMatch>

    <FilesMatch “\.(jpg|jpeg|png|gif|swf|webp)$”>
    Header set Cache-Control “max-age=691200”
    </FilesMatch>
    </IfModule>
    # END WP-HUMMINGBIRD-CACHING

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Dear @ysmr,
    please create a separate thread about your issue, as mentioned above (and in wp.org forum regulations here: https://make.wordpress.org/support/handbook/forum-welcome/#post-in-the-best-place)

    Unless users have the exact same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme, and configurations, then the odds are the solution for one user will not be the same for another. For this reason, we recommend people start their own topics.

    Dear @rafatfe,
    please send us an email using our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question
    and following template:

    Subject: “Attn: Dimitris
    – link back to this thread for reference

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @ysmr,

    I just checked your website, and GZIP is working fine for all three file types. It is still not showing up in Hummingbird as enabled? Have you tried clicking the “Re-check status” button?

    Best regards,
    Anton

    Zmokin

    (@zmokin)

    Hello,

    I have the same setup and host (1and1) as rafatfe and have added all the code (that you suggested as well as that from 1and1) to the htaccess file and am getting the same results – or should I say, lack of results.

    All sites that look for gzip say gzip is activated:
    https://www.1and1.com/website-checker?ar=1
    https://checkgzipcompression.com/?url=https%3A%2F%2Fvoteforedpope.com%2F

    Yet Hummingbird continues to report that Javascript and css are “inactive”.

    Please advise.

    Thanks for your time.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Gzip compression not working’ is closed to new replies.