Support » Plugin: Font Awesome » Guttenberg Editor error After update to 4.0 from 4.0.0-rc23

  • Resolved wongkediri

    (@wongkediri)


    hi please check, updating from 4.0.0-rc23 to 4.0
    make post edit not loading/blocking render.

    * using flatsome theme

    • This topic was modified 1 year, 3 months ago by wongkediri.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author mlwilkerson

    (@mlwilkerson)

    Thanks for the report. Do you see any relevant diagnostic messages in the JavaScript console when the problem occurs?

    Seeing same issue – edit page loads with the word “document” in upper left corner and page is blank. Only appears to be happening on sites using woocommerce.

    Plugin Author mlwilkerson

    (@mlwilkerson)

    Hi @tanyaslogos are you using the same theme? Or are you using a different theme, but also with WooCommerce?

    What version of WooCommerce is in use?

    update: just loaded another site that was NOT using WOO and it did the same thing. GENESIS MAI DELIGHT theme & GENESIS MAI LIFESTYLE PRO theme

    Error log shows this on two different sites

    [06-Aug-2021 03:24:18 UTC] Sync process for Gutenberg Blocks has started.
    [06-Aug-2021 03:24:18 UTC] CATEGORY:Importing categories..
    [06-Aug-2021 03:24:18 UTC] CATEGORY:Storing in option ast-block-templates-categories
    [06-Aug-2021 03:24:18 UTC] CATEGORY:Completed category import.
    [06-Aug-2021 03:24:18 UTC] BLOCK: Getting Total Blocks
    [06-Aug-2021 03:24:18 UTC] BLOCK: https://websitedemos.net/wp-json/astra-blocks/v1/get-blocks-count/?page_builder=gutenberg
    [06-Aug-2021 03:24:18 UTC] BLOCK: Requests count 3
    [06-Aug-2021 03:24:18 UTC] BLOCK: Importing request 1 ..
    [06-Aug-2021 03:24:18 UTC] BLOCK: https://websitedemos.net/wp-json/astra-blocks/v1/blocks/?page_builder=gutenberg&per_page=100&page=1
    [06-Aug-2021 03:24:18 UTC] BLOCK: Storing in option ast-block-templates-blocks-1
    [06-Aug-2021 03:24:18 UTC] BLOCK: Completed request 1
    [06-Aug-2021 03:24:18 UTC] BLOCK: Importing request 2 ..
    [06-Aug-2021 03:24:18 UTC] BLOCK: https://websitedemos.net/wp-json/astra-blocks/v1/blocks/?page_builder=gutenberg&per_page=100&page=2
    [06-Aug-2021 03:24:18 UTC] BLOCK: Storing in option ast-block-templates-blocks-2
    [06-Aug-2021 03:24:18 UTC] BLOCK: Completed request 2
    [06-Aug-2021 03:24:18 UTC] BLOCK: Importing request 3 ..
    [06-Aug-2021 03:24:18 UTC] BLOCK: https://websitedemos.net/wp-json/astra-blocks/v1/blocks/?page_builder=gutenberg&per_page=100&page=3
    [06-Aug-2021 03:24:18 UTC] BLOCK: Storing in option ast-block-templates-blocks-3
    [06-Aug-2021 03:24:18 UTC] BLOCK: Completed request 3
    [06-Aug-2021 03:24:18 UTC] SITE: Getting Total Sites
    [06-Aug-2021 03:24:18 UTC] SITE: https://websitedemos.net/wp-json/astra-sites/v1/get-total-pages/?page_builder=gutenberg
    [06-Aug-2021 03:24:19 UTC] SITE: Request count 1
    [06-Aug-2021 03:24:19 UTC] SITE: Importing request 1 ..
    [06-Aug-2021 03:24:19 UTC] SITE: https://websitedemos.net/wp-json/astra-sites/v1/sites-and-pages/?per_page=100&page=1&page-builder=gutenberg
    [06-Aug-2021 03:24:19 UTC] SITE: Storing in option ast-block-templates-sites-1
    [06-Aug-2021 03:24:19 UTC] SITE: Completed request 1
    [06-Aug-2021 03:24:19 UTC] Sync process for Gutenberg Blocks is done.

    I Updated another site that was using Generate Press without WOO and it didn’t have a problem so that is why I thought it was a WOO issue.

    However, when I updated another site that wasn’t using WOO but was using GENESIS I got the same error. None of my sites use ASTRA blocks but both the sites that have the issue and the site that doesn’t have the issue are using Ultimate Addon for Gutenberg. Since the site that works is using this plugin as well I ruled it out but it might be a combo situation.

    Plugin Author mlwilkerson

    (@mlwilkerson)

    There seems to be some sort of bad interaction happening between this plugin and some combination of other pieces of software. I haven’t yet been able to reproduce the problem. But I also don’t have access to all of those premium themes in order to try various scenarios.

    @wongkediri I did try the Flatsome theme and saw no errors. That suggests that it isn’t merely the presence of the Flatsome theme, but that there’s some additional configuration that is impacting how that page is being loaded. I need to figure out what that is.

    If someone would be willing to let me investigate directly on your site where the problem is happening, we could coordinate that through Font Awesome support. (Don’t post any private information in this public support forum.) You could email hello at fontawesome.com and ask for me, Mike, about the WordPress plugin 4.0.0 release.

    Hello Mike, I sent you an email

    Thread Starter wongkediri

    (@wongkediri)

    rollback to previous version (4.0.0-rc23) the problem gone.

    on page load do browser debug throw error regarding hooks.min.js
    The hook name can only contain numbers, letters, dashes, periods and underscores

    o @ hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1:2
    hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1:2 The hook name can only contain numbers, letters, dashes, periods and underscores.

    o @ hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1:2
    post.php?post=6094674&action=edit:3422 woocommerce_shared_settings filter in Blocks is deprecated. See https://github.com/woocommerce/woocommerce-gutenberg-products-block/blob/trunk/docs/contributors/block-assets.md

    (anonymous) @ post.php?post=6094674&action=edit:3422
    deprecated.min.js?ver=be1d4376501c21d85ba98dd28ca2d7ea:2 Button isDefault prop is deprecated. Please use isSecondary instead.

    c @ deprecated.min.js?ver=be1d4376501c21d85ba98dd28ca2d7ea:2
    editor.min.js?ver=dbf1015c024ecc3b432a2a5d7898e51d:12 [Violation] ‘setTimeout’ handler took 533ms`

    • This reply was modified 1 year, 3 months ago by wongkediri.

    Hey. How can I rollback to the previous version? I am going on vacation today so this really is quite urgent. Same thing happening on my installation

    Thread Starter wongkediri

    (@wongkediri)

    @katjavolker easiest way is using wp rollback plugin

    Thanks @wongkediri. I found that just before your answer 🙂

    Same issue here. WordPress 5.7 with a custom theme.
    Errors in the Firefox console are:
    downloadable font: rejected by sanitizer (font-family: “FontAwesome” style:normal weight:400 stretch:100 src index:0) source: https://use.fontawesome.com/releases/v5.11.2/webfonts/fa-regular-400.eot
    downloadable font: rejected by sanitizer (font-family: “FontAwesome” style:normal weight:400 stretch:100 src index:0) source: https://use.fontawesome.com/releases/v5.11.2/webfonts/fa-solid-900.eot

    Disabling the plugin allows the editor to load.

    I’m no an expert but it looks like something has gone wrong in the build process if you look at the release diff.

    As an example, admin/build/static/css/8.8fbf84c5.chunk.css appears to be a copy of the stock WordPress file /wp-includes/css/dist/components/style.min.css and this is causing a lot of issues with the editor as it messes with the intended CSS order.

    • This reply was modified 1 year, 3 months ago by clamburger.

    Same issue here, when I try to edit Learndash pages I get the blank screen with just ‘Document’. Editing non Learndash pages work fine. My site is:

    GeneratePress theme (child)
    Woocommerce is active (deactivating it does not fix the issue)

    The issue is on a staging site where I have a backup from tghis morning so you’re more than welcome to get an admin account and play around in there (I’ve emailed you)

    Seeing same issue on WP 5.8 running the Astra theme along with ACF. Disabling the FontAwesome 4.0 plugin fixes the issue.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Guttenberg Editor error After update to 4.0 from 4.0.0-rc23’ is closed to new replies.