Support » Plugin: Gutentor - Gutenberg Blocks - Page Builder for Gutenberg Editor » Gutentor loading unused scripts

  • Resolved knzzz

    (@knzzz)


    Gutentor is loading google map scripts to the frontend, and the site is not using the maps block anywhere.

    This is the script thats loading;
    <script src="https://zapscale.com/wp-content/plugins/gutentor/assets/js/google-map-loader.min.js?ver=1.0.0" id="gutentor-google-maps-js"></script>

    Didn’t see any settings to avoid scripts from unused blocks. What can be done about this? Can I manually dequeue the scripts somehow?
    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor codersantosh

    (@codersantosh)

    Hello @knzzz ,

    Can you please go to Gutentor => Setting => Optimization => Resources Load and check if it is selected Force load? You can select Default or Disable as you need.

    Best Regards!

    Thread Starter knzzz

    (@knzzz)

    Hello @codersantosh,

    All the dropdowns on that page are set as “Default”. Moreover, there’s no Google Maps dropdown in there.
    I was able to remove all the Google Maps scripts by going to Gutentor => Setting => General => Google Maps API Key and emptying the API key input box. This removed google-maps-js, gutentor-google-maps-js, and <link rel='dns-prefetch' href='//maps.googleapis.com' />. Adding it back made it come again. seems like this is not the expected behavior, but yeah, it’s fixed for now.

    Thanks!

    Plugin Contributor codersantosh

    (@codersantosh)

    Hello @knzzz, thanks for the input we will add a Google Maps dropdown on the next update.

    Plugin Contributor codersantosh

    (@codersantosh)

    Hello@knzzz ,

    We have added missing Google Map Script on Gutentor => Setting => Optimization => Resources Load. If you find any further issues feel free to add a support thread.

    Best Regards!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.