Support » Fixing WordPress » Gutenberg YouTube Block Not Displaying in Posts Only

  • I have embedded a YouTube video in a blog post in the new Gutenberg block editor. In the post backend, the embedded YouTube video block looks perfect… but when I publish it and look at the live post, only the YouTube video caption appears.
    EXAMPLE: coursenvy .com/coinbase

    NOTE: It is JUST not working on blog posts. When I embed YouTube videos into new pages, they do appear on the live website page.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hey
    Can you provide me the Url which you are trying to embed.
    It can be a bug https://github.com/WordPress/gutenberg/issues/8411
    But first provide me your Url so that I can test it in my local machine and than I will be able to provide you solution.
    Thank You

    I embedded a video on this new Gutenberg block blog post (you can even see the caption appearing under step #1): https://www.coursenvy.com/coinbase/

    Then for a classic editor blog post example: https://www.coursenvy.com/teikametrics-managed-amazon-ads/ (under H2 “Teikametrics 101” there should be an iframe YouTube embed that appears, which does in the backend editor, just not on the live website)

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @coursenvy, what are the actual youtube URLs that you are trying to embed?

    marshlawfirm

    (@marshlawfirm)

    Was this ever resolved? I am having this exact same problem.

    Mike Clayton

    (@mike-clayton)

    Me too – my posts are just displaying the URL – and not even as a link.

    Me too. Looks just like my older posts, in the HTML editor. The only difference is some were made before the block update and others after. The ones after, do not display correctly. I am going to go into the database to see the difference.

    Tried the youtube block feature and the text embed. Neither worked. The youtube block said “Sorry, this content could not be embedded.”

    • This reply was modified 10 months, 1 week ago by lanesharon.

    Workaround – used the embed youtube code in the HTML block. Worked fine. So, I would say it is the YOUTUBE block that is not working correctly on Gutenberg.

    • This reply was modified 10 months, 1 week ago by lanesharon.
    GlobalCreations

    (@globalcreations)

    I was having this problem at
    https://explore.globalcreations.com/uncategorized/cairn-subscription-service/
    with https://youtu.be/BFqGS6llgFs and WordPress 5.2.1.

    Video worked fine in the block editor, but only the link appeared in the preview or published version. I tried putting the YouTube block code into an HTML block and publishing another article, but neither solved the problem.

    I noticed the link was “uncategorized” so I unset uncategoried in the Quick Editor and set a new primary category. Now this link displays the video properly:
    https://explore.globalcreations.com/reviews/cairn-subscription-service/

    This suggests a cache issue, but before I messed with the link, I tried clearing browser caches and WP Super Cache and that didn’t help.

    I have exactly the same problem: the video appears in the editor, but not in the post. Even the caption does not appear. On the published page I get just a single <p>&nbsp</p> where the video should appear.

    Worse, once I add the YouTube embed block, the rest of the post below is not visible in the editor.

    Just pasting in a YouTube URL works fine, in both editor and post, but then I can’t center the video or add a caption.

    Adding a category other than “uncategorized” did not work.

    My site is jonathanstray.com. This is WP 5.2.2 with an old theme called Toko from 2014

    • This reply was modified 9 months, 2 weeks ago by .
    • This reply was modified 9 months, 2 weeks ago by .
    brideauj

    (@brideauj)

    I was having this problem too. It seems to be an issue with the url provided by Youtube in the “creator studio(beta)”

    If i use the suggested “Video URL” from the editor as: https://youtu.be/XV4HMSedEI0

    It does not work

    If I click that link in the editor and then use the URL in the browser address bar as:https://www.youtube.com/watch?v=XV4HMSedEI0

    It works

    ahardy42

    (@ahardy42)

    @brideauj that’s it – exactly the same problem for me.

    They were working for 2 weeks since I put the site live, and suddenly today the embedding didn’t work.

    I changed the youtube URLs and it’s fine now – phew!

    brideauj

    (@brideauj)

    @ahardy42 It works, but it’s a shame you have to open and view a video to get the right URL vs. copying from the YouTube console.

    I too am having the same issue. Only on posts as the other

    Same issues, even after the latest updates to WordPress 5.3

    I am assuming this still hasn’t been resolved?

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.