Support » Plugin: KIA Subtitle » Gutenberg & WP 5.0 Issue

  • Resolved irfoxm

    (@irfoxm)


    Please add Gutenberg support. I test it out on v5.0 WP and find that whenever a Post is being updated, Published or save in draft, all things in kia subtitle fields just fade away and gone…
    Hope you get around and Solve it !!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author helgatheviking

    (@helgatheviking)

    Hi @irfoxm, I’m at WordCamp US trying to finally learn a bit about Gutenberg. How do you think this would function? Like what would work for you? It seems like you can create a “subtitle” with a heading block, but it’s important to keep all the old data, so I’m open to all kinds of ideas.

    Hey @helgatheviking, most of the things working fine. Apparently newer WP release with Gutenberg allows to create custom fields and subheading block. With kia subtitle plugin, there already a custom field in Post editor Have a look. But there is Content Disappearing Glitch, it means anything in kia subtitle field gone or blank after save draft, publishing.
    All Good, looking forward for new things from you.
    Thanks…

    • This reply was modified 4 months, 2 weeks ago by  irfoxm.
    Plugin Author helgatheviking

    (@helgatheviking)

    @irfoxm Would you try this developmental branch of the plugin?
    https://github.com/helgatheviking/kia-subtitle/tree/dev

    It converts the input to a metabox which is compatible with Gutenberg. I will think about learning the Gutenberg Sidebar (I want to anyway, but I’m not sure if this is better served in the sidebar or not. Certainly, this way was much easier)

    Hi There! @helgatheviking, It works, there is sidebar subtitle entry field. So basically it’s fine, Now there is two fields to put things there, I mean one is Sidebar subtitle field and other is custom kia subtitle fields. Custom kia subtitle fields has bug of WordPress custom field or Plugin,I don’t know !
    Problem with custom field is things or changes in custom field gone after saving draft or publish but Sidebar field working fine. I test out differ plugin about custom field but all have same issue. I’m going to open this up to WP bug report, so they can fix it in the next release.
    So things are all Good πŸ‘
    Thanks, developer !!

    Plugin Author helgatheviking

    (@helgatheviking)

    It’s in the sidebar? Could you send me a screenshot as that sounds different from what I’m seeing.

    the subtitle has always been in the Custom Fields metabox since the key is kia_subtitle and not prefixed by an underscore _. That was probably a mistake on my part, but I’m not inclined to write a database upgrade at the moment. I would like to see if there’s another way to keep the subtitle out of the Custom Fields box. Showing up in 2 places (or more?) is confusing for users.

    @helgatheviking,
    Screenshot 1 :: https://res.cloudinary.com/foxm/image/upload/v1544495052/Ingsrc_ks.png
    ____________________

    Screenshot 2 ::
    https://res.cloudinary.com/foxm/image/upload/v1544495204/Kngsybjo_1.png
    _________________________________________

    Alright, it’s there in the sidebar fields like else plugin and all things are going right. Plus wordpress 5.0 release has feature to build own custom fields in the post editor page > show more tools and options > Options > scroll to advanced Panels and Tick on the Custom Fields. it’s default to appear in there like any other custom fields plugins, see screenshot 2. So I think it’s not misleading to appear in two Places, if options turned on by user. So, All Good !
    Maybe you think something more by your side, that I can’t be understand !

    Plugin Author helgatheviking

    (@helgatheviking)

    I thought you meant this sidebar: https://cl.ly/170e94147d46
    But you didn’t so we’re on the same page. πŸ™‚

    I’ve found the filter that lets me mark the field as private (which is what it would have been if I’d prefixed it with an underscore). So I think that’s good enough for now.

    I will try to get it packaged up and released to the repo later today. Thanks for your help testing this.

    Yeah, It’s been nice experience with You. Excited to get there at these things.πŸ‘
    Thank you !!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.