Support » Fixing WordPress » Gutenberg = updating failed

  • Damn…

    Whatever I do I get the “updating failed”.
    Inserting a link, trying to publish… whatever I do 🙁

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter fancybug

    (@fancybug)

    Ok, I’ll go: https://wordpress.org/plugins/classic-editor/

    Then it works all good!

    Damn!
    Solved!

    PS: what a great ‘progress’ is Gutenberg ^^

    Moderator Marius L. J.

    (@clorith)

    Hi there,

    It sounds like you’re encountering one of multiple possible scenarios here, so I’d ask if you would be able to provide us with the error message from your JavaScript console (https://wordpress.org/support/topic/read-this-first-wordpress-5-0-master-list/#post-10953587 has some information on how to obtain this if you’re not familiar with it), as that will help pinpoint where we should be looking to find the problem you are experiencing.

    Thread Starter fancybug

    (@fancybug)

    You’ll tell me if it’s of some use…

    After disabling the ‘classic editor’ plugin (not deleted it), came back to the edition page with, of course, Gutenberg editor; tried some link insertion on some text… got the ‘update fail’ on automated update, CTRL+SHIFT+J got me:

    Error while calling actor 'parentProcessTarget's method 'ensureCSSErrorReportingEnabled' Argument 1 of InspectorUtils.getAllStyleSheets is not an object. protocol.js:1021:5
    ensureCSSErrorReportingEnabled@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1012:9
    handler@resource://devtools/shared/base-loader.js -> resource://devtools/shared/protocol.js:1178:21
    onPacket@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:1721:15
    send/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:64:11
    exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
    exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
    protocol.js:1024:7
    Promise rejected after context unloaded: Promised response from onMessage listener went out of scope
    page_performance.js:18
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    Promise rejected after context unloaded: Promised response from onMessage listener went out of scope
    page_performance.js:18
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope
    page_performance.js:18
    Promise rejected after context unloaded: Promised response from onMessage listener went out of scope
    page_performance.js:18
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    Error while calling actor 'parentProcessTarget's method 'ensureCSSErrorReportingEnabled' Argument 1 of InspectorUtils.getAllStyleSheets is not an object. protocol.js:1021:5
    ensureCSSErrorReportingEnabled@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1012:9
    handler@resource://devtools/shared/base-loader.js -> resource://devtools/shared/protocol.js:1178:21
    onPacket@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:1721:15
    send/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:64:11
    exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
    exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
    protocol.js:1024:7
    Error while calling actor 'parentProcessTarget's method 'ensureCSSErrorReportingEnabled' Argument 1 of InspectorUtils.getAllStyleSheets is not an object. protocol.js:1021:5
    ensureCSSErrorReportingEnabled@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/browsing-context.js:1012:9
    handler@resource://devtools/shared/base-loader.js -> resource://devtools/shared/protocol.js:1178:21
    onPacket@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:1721:15
    send/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:64:11
    exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
    exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
    protocol.js:1024:7
    Promise rejected after context unloaded: Promised response from onMessage listener went out of scope
    page_performance.js:18
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18 

    I’m not sure at all it’s of any use.

    Thing is I also had some 403 each time: autosaves?_locale=user

    I’m also getting this on a fresh install on Ubuntu 18.04 server. No plugins except Akismet.

    JQMIGRATE: Migrate is installed, version 1.4.1
    jquery-migrate-1.4.1.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
    /wp-json/wp/v2/taxonomies?context=edit&_locale=user:1 Failed to load resource: the server responded with a status of 404 (Not Found)
    redux-routine.min.js?ver=3.0.3:1 Uncaught (in promise) Error: [object Object]
    at redux-routine.min.js?ver=3.0.3:1
    at redux-routine.min.js?ver=3.0.3:1
    /wp-json/wp/v2/users/?who=authors&per_page=100&_locale=user:1 Failed to load resource: the server responded with a status of 404 (Not Found)
    redux-routine.min.js?ver=3.0.3:1 Uncaught (in promise) Error: [object Response]
    at redux-routine.min.js?ver=3.0.3:1
    at redux-routine.min.js?ver=3.0.3:1
    /wp-json/wp/v2/types/wp_block?_locale=user:1 Failed to load resource: the server responded with a status of 404 (Not Found)
    editor.min.js?ver=9.0.4:12 Uncaught (in promise) Object
    2/wp-json/wp/v2/pages/13?_locale=user:1 Failed to load resource: the server responded with a status of 404 (Not Found)

    Installing the Classic Editor plugin and using that gives no issues. So there’s plainly a pretty basic issue with Gutenberg. 🙁

    I was having this issue with a new install, adding an .htaccess file fixed it.

    Ah – you’re right. This seems to sort it. Thanks!

    Hi, I’m experiencing the same issue. Can you explain what you mean by “adding an .htaccess file fixed it”? Do you mean replace the .htaccess file with a new .htaccess one? Thanks!

    To Everyone stumbling onto this question. The issue tends to be related to how the routing is being handled in your permalinks. Most of the time a website author is going to change the “Permalinks” from the “parameter driven” urls that is the WordPress default to something that is more SEO friendly. If this setting has been changed and your .htaccess file is not configured to rewrite the URL’s properly, the UI will fail.

    In my case, I use nginx and will need to configure the rewrites to support SEO without .htaccess.

    For now I switched my “Permalinks” back to the parameter-driven setting and all is well.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Gutenberg = updating failed’ is closed to new replies.