Support » Fixing WordPress » Gutenberg: Tags disappear on entry

  • Takkunl

    (@takkunl)


    I’ve upgraded to WP 5.0.2 and I’m encountering problems with the new Gutenberg editor. When I try to add post tags, the tags just randomly disappear when adding them. Only 2 tags get saved and it seems to be random what tags get saved and what tags don’t

    Using the Troubleshooting mode on the Health Check plugin doesn’t seem to help either. All plugins and themes have been disabled in this mode and still the block editor comes up with the same problems. Could this be a serverside issue? Anyone experiencing the same?

Viewing 6 replies - 46 through 51 (of 51 total)
  • zionthelion73

    (@zionthelion73)

    Maybe is some tag cache

    plagiarismtoday

    (@plagiarismtoday)

    Ok, I have another wrinkle here. This might help some.

    What I tried was typing a tag (or rather starting one), letting it autosuggest, and then deleting what I typed. Lather, rinse, repeat for about 10 tags. On the server-side, I’m seeing the EXACT same issue.

    This problem isn’t about WRITING tags, it’s about something in the tag recommendation process. I also don’t see the issue with deleting tags.

    This also explains why working within the quick edit doesn’t cause the problem, there’s no tag recommendation. Is there any way to disable tag recommendation in Gutenberg? It isn’t very helpful to me anyway.

    I’d also disable the tag auto-complete in Gutenberg if possible to fix the issue. But it’s weird that you say that, @plagiarismtoday, as I do see a similar feature in the quick editor; it does auto-complete tags for me, but it doesn’t show any of the issues that we’re seeing in Gutenberg.

    plagiarismtoday

    (@plagiarismtoday)

    @rfischmann You’re right. I guess I just type so fast I never see it. On mine, it takes a good bit to pop up. I did the same experiment there (adding, letting autofill kick in and deleting tags) without any server load or performance issues.

    Something is different about the query for the tag preview in Gutenberg than the one in quick edit. Find out what’s different, I think you’ve solved your problem. Sounds like I may be able to get help from my girlfriend here, she’s a database administrator.

    Now that we know what to look at and compare, if it’s a database issue, she may be able to help diagnose. Will see if we have time over the weekend.

    ddrager

    (@ddrager)

    Hey guys, I have some good (or maybe bad news), I think I know what is causing this problem. It likely only occurs on sites with a large number of tags.

    When you start typing, for example let’s say you want to add “android” as a tag:

    1. Type a, Gutenberg sends request to fetch all tags with “a” in them.
    2. Type an, Gutenberg sends request to fetch all tags with “an” in them. Request 1 continues.
    3. Type and, Gutenberg sends request to fetch all tags with “and” in them. Request 1 and 2 are still occurring.

    Each request fetches 100 tags at a time. If you have 5,000 tags, and 3100 of them has “a” in it, it sends a request for 32 pages of tags.

    You can see the network log of requests here:
    https://i.imgur.com/tSAH8k9.png

    In this log, you can see there are actually 3 simultaneous requests, one for “a”, “and”, and “android”. The “a” request causes the most problems as it is 32 pages of json requests.

    My blog had 13k tags, after trimming tags to 5k (by eliminating tags with 1 post, for example), the problem is a little better, but our editors are still having problems adding tags in the Gutenberg editor.

    To fix this problem, I would recommend increasing the page size for blogs with large number of tags, cancelling the old request once a new character is typed into the tags box, or only fetch tags when a minimum of characters is typed.

    That’s some great analysis there, @ddrager, thanks. I hope it does help the WordPress’ devs solve this issue for us with large tag databases.

Viewing 6 replies - 46 through 51 (of 51 total)
  • You must be logged in to reply to this topic.