Support » Fixing WordPress » Gutenberg: Tags disappear on entry

  • I’ve upgraded to WP 5.0.2 and I’m encountering problems with the new Gutenberg editor. When I try to add post tags, the tags just randomly disappear when adding them. Only 2 tags get saved and it seems to be random what tags get saved and what tags don’t

    Using the Troubleshooting mode on the Health Check plugin doesn’t seem to help either. All plugins and themes have been disabled in this mode and still the block editor comes up with the same problems. Could this be a serverside issue? Anyone experiencing the same?

Viewing 15 replies - 31 through 45 (of 51 total)
  • I’ve followed your advice and upgraded MariaDB to 10.3 (and also PHP from 7.1 to 7.2), but saw very few to no improvements at all with this tag issue.

    I basically gave up on the idea of adding tags through Gutenberg’s interface. I only do it via the quick/batch editor, now.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    This doesn’t really give any information. Yes, adding a tag is going to cause hits to your site. Doing pretty much anything on this screen is going to cause hits to your site.

    This is how the new editor works, it uses the REST API to retrieve information from the server. When you do something, it makes an HTTP request to the server to get the info it needs, or to add the tag, or to do pretty much anything else, really. The question is, why is your server being so slow to respond to these requests?

    Basically, you need to find the bottleneck on the server, and fix that. Whatever it may be. It could be the database, if you have an extreme amount of tags, and this problem is only happening with manipulation of those tags. Maybe you should reduce that number of tags, or optimize the taxonomy tables in the database, or move the database off onto its own server, or something. It’s impossible to say without actually analyzing the issue directly.

    I’m sure the reasons you’ve mentioned for the slowness are all valid, @otto42, and yes: I have 54,439 tags in my database, but that’s normal for a big/popular site that has been running on WordPress for 13 years.

    The thing is that inserting tags via the quick/batch editor doesn’t cause any issues at all to the server, and it also autocompletes tags just as inside Gutenberg. So there’s something bad going on there.

    I really don’t think the answer here is to double our server’s capacity just so that Gutenberg can handle inserting tags in a post. What the WordPress’ developers should do is test it out in a heavy-duty environment with a huge database like ours, which isn’t something uncommon these days.

    @rfischmann
    Wordpress has just update Gutemberg module, but there’s no mention to tag fixes…
    I don’t know how to install it…
    regards

    If a large amount of tags can cause then then that’s likely my issue too. I have about 7K tags in my database. While that’s a lot, it’s not a huge amount for a 15-year-old site with nearly 5K posts.

    Literally nothing else on the site runs slow, server load is extremely light (in spite of getting thousands of visitors per day) and all of the editing in Gutenberg that isn’t tag related is swift and gentle on the server.

    Is there a way to disable to tag preview feature? The one where it tries to guess what tag you want? If it’s caused by a lot of tags then that might fix it because, as others have noted, using the quick edit (which doesn’t have that feature) is just fine. Maybe turning that off (and eliminating the queries it causes) would help.

    I’d also wanted to be able to disable the tag auto-completion feature inside Gutenberg, but bear in mind that it also exists and works without any server issues using the quick/batch editor, @plagiarismtoday.

    Maybe what Gutenberg should do is only look for tags to auto-complete, let’s say, 1 second after the user stopped typing something. I think that’s the main issue today; it starts and keep querying the server continuously, all the time, as you begin typing in the tags’ field.

    I can’t save tags at all! Nothing, zip, nada, They just disappear. There is clearly a problem here. I’m on 5.2.4–en_GB. At least on 5.2.3 I could save tags even if it was one at a time!

    Ah I just discovered they are saving – You just have to type them in and not paste them in…

    • This reply was modified 1 week, 5 days ago by platothefish.
    • This reply was modified 1 week, 5 days ago by platothefish.
    • This reply was modified 1 week, 5 days ago by platothefish.

    With quick edit in all posts run ok and all the tags appear, I no understand why they no solve it

    Create tags in the command menu then create a post and recall them, there’s no option at the moment.

    zionthelion73

    (@zionthelion73)

    Just installed a fresh and new versione: 5.3
    Bugs seems fixed!
    please confirm it!
    cheers

    plagiarismtoday

    (@plagiarismtoday)

    I just tested it and it is still a bug on mine, even doing a complete reinstall (via the backend).

    It’s not as severe as it was previously, there is more marked improvement, but it’s still there.

    zionthelion73

    (@zionthelion73)

    @plagiarismtoday oka. Sure to have 5.3 version.
    Regards

    Nothing changed for me on 5.3, issue persists. What a shame.

    @rfischmann fresh installation?

    Of course not.

Viewing 15 replies - 31 through 45 (of 51 total)
  • You must be logged in to reply to this topic.