Support » Plugin: Mammoth .docx converter » Gutenberg support

  • Do you plan to add Gutenberg support to this plugin? I can select a Word document using the metabox at the bottom of the screen, but when I try to insert it, I just see “Inserting…”

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Michael Williamson

    (@michaelwilliamson)

    I haven’t had a chance to play around with Gutenberg yet, but I’ll take a look if I get a chance.

    With Gutenberg launch coming close, allow me to revive this thread…

    I am not pleased at all with Gutenberg, but if we want to continue using WordPress, we may have to learn living with it. For the time being, I have already activated Classic Editor + Disable Gutenberg (by Jeff Starr) on a majority of my sites.

    In addition to the issue already raised by @abrightclearweb, a major challenge will be inserting a Word document with footnotes, due to the block logic of Gutenberg.

    Anyway, if you find time to play with Gutenberg and can devise some solutions within the coming months, I am sure that many users of your wonderful plugin will be greatly interested to hear more. But I am aware that this might take time (moreover, the plugin will need to be maintained for those who want to continue using the Classic Editor for as long as possible).

    If you manage to develop a Gutenberg version, this may represent a major time investment for you. If such is the case and you need to make a Gutenberg version of the plugin a paid one, I am sure that many users would fully understand that. What you have developed has so often been very useful for many of us. Thank you once again.

    Plugin Author Michael Williamson

    (@michaelwilliamson)

    I’ve just released 1.12.0, which has an attempt at very basic Gutenberg support. If Gutenberg is detected, then the content is inserted as a new Classic block. Having better integration with Gutenberg would be nice, such as making it a block type, but it’s unlikely I’ll find time to do so.

    I haven’t had much time to test it out, so reports of the plugin either working or not are helpful.

    Same here, I don’t like Gutenberg at all, then I activated the Disable Gutenberg plugin: https://wordpress.org/plugins/disable-gutenberg/

    Problem is that your plugin doesn’t work (it doesn’t paste the text in the classic editor).

    Any chance, you take a look a this?

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Gutenberg support’ is closed to new replies.