Support » Plugin: The Events Calendar » Gutenberg Plugin 8.1.0 Completely Broke Week View

  • FYI, the new version of Gutenberg, v8.1.0, just completely broke Calendar Week View (or at least as displayed from shortcode). Now it’s just a bunch of errors and it doesn’t load completely. See screenshot:

    https://i.imgur.com/33PG7ZS.png

    Downgrading to Gutenberg 8.0.0 fixes it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support sjaure

    (@sjaure)

    Hi @brianbws,
    Thanks for getting in touch,

    I would like to have some more context to see if this is generated by a specific setup in your site. Could you please share your system information in your reply?
    Also, does this affect any other calendar view in any way? How does it look in the front end?

    Thanks in advance for your reply.

    Best
    Santiago

    @sjaure See steps to reproduce:

    Fresh install of WordPress v5.4.1 locally. Any default theme.
    In wp-config.php, define( ‘WP_DEBUG’, true );
    Add plugins:
    The Events Calendar 5.1.2
    Gutenberg v8.2.0 or v8.1.0

    Add an event.

    Go to calendar root. http://test.test/events/

    Switch from list view to month view and then back to list view:

    https://i.imgur.com/xKTXlxM.png

    This only prints 2 notices here, but every event you add brings 2 more notices until i think it eventually breaks the calendar completely.

    Please fix.

    Plugin Support sjaure

    (@sjaure)

    Hi @brianbws,

    Thanks for sharing the steps to reproduce the error.
    I’ve tried using Gutenberg 8.2.1 with the same setup as you shared and the views selector works just fine.
    Could you try updating to the latest version of Gutenberg just in case?

    If the issue persists, I’d appreciate if you could share your site’s system information in your reply. You can find it under Events->Help

    Let me know how it goes.

    @sjaure Yes, it is still bugged with Gutenberg 8.2.1.

    Here it is as a gif:
    https://i.imgur.com/x700Cr8.gifv

    Here is system info.

    HOME URL
    http://test.test
    SITE URL
    http://test.test
    SITE LANGUAGE
    English
    CHARACTER SET
    UTF-8
    NAME
    admin
    EMAIL
    dlsjdfkljsf@gmail.com
    INSTALL KEYS
    -
    WORDPRESS VERSION
    5.4.1
    PERMALINK STRUCTURE
    http://test.test/%year%/%monthnum%/%day%/%postname%/
    YOUR HOMEPAGE DISPLAYS
    posts
    HOMEPAGE PAGE ID
    -
    PHP VERSION
    7.4.5
    PHP
    max_execution_time = 36000
    memory_limit = 512M
    upload_max_filesize = 2G
    post_max_size = 2G
    display_errors = 1
    log_errors = 1
    SERVER
    nginx
    SAPI
    cgi-fcgi
    PLUGINS
    Gutenberg version 8.2.1 by Gutenberg Team
    The Events Calendar version 5.1.2 by Modern Tribe, Inc. (http://m.tri.be/1x)
    NETWORK PLUGINS
    -
    MU PLUGINS
    -
    THEME
    Twenty Nineteen
    MULTISITE
    -
    SETTINGS
    schema-version = 5.1.2
    previous_ecp_versions =
    Array
    (
        [0] => 0
        [1] => 5.1.1
    )
    latest_ecp_version = 5.1.2
    tribeEnableViews =
    Array
    (
        [0] => list
        [1] => month
        [2] => day
        [3] => photo
        [4] => map
        [5] => week
    )
    views_v2_enabled = 1
    postsPerPage = 12
    monthEventAmount = 3
    recurring_events_are_hidden = hidden
    pro-schema-version = 3.9
    earliest_date = 2020-06-04 08:00:00
    earliest_date_markers =
    Array
    (
        [0] => 5
    )
    latest_date = 2020-06-04 17:00:00
    latest_date_markers =
    Array
    (
        [0] => 5
    )
    WP TIMEZONE
    Unknown or not set
    WP GMT OFFSET
    Unknown or not set
    DEFAULT PHP TIMEZONE
    UTC
    WP DATE FORMAT
    F j, Y
    WP TIME FORMAT
    g:i a
    WEEK STARTS ON
    1
    COMMON LIBRARY DIR
    D:\laragon\www\Test\wp-content\plugins\the-events-calendar/common/src/Tribe
    COMMON LIBRARY VERSION
    4.12.3

    Also get this problem on a localhost system

    WP 5.4.1
    Twenty Nineteen Theme
    Gutenberg 8.2.1
    TEC 512

    The problem seems to be that compat.php is trying to read the $post after the last Event. Which doesn’t exits.

    @sjaure This is still bugged in Events Calendar TEC 5.1.4, Gutenberg 8.4.0.

    Any updates? I already gave the exact steps to reproduce along with a gif file demonstrating the problem.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.