Support » Plugin: Gutenberg » Gutenberg not saving

  • Resolved MastaBaba

    (@mastababa)



    I’ve got my WordPress install in a different folder from where I serve my website from. That is, I serve my site from https://mysite.com, with WordPress residing at https://mysite.com/wordpress/.

    When using Gutenberg, saving a post in the editor fails, “Update failed”. I can see in the console that WordPress is trying to access pages under the root, not under /wordpress/.
    Using the regular editor, updating posts works fine.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have a similar configuration with wordpress installed in a subdirectory and I got the same problem with Gutenberg when saving my job.

    Moderator Marius L. J.

    (@clorith)

    Hi,

    Sorry for the slow followup here, are you still experiencing these issues with Gutenberg 3.9.0?

    If so, could you try visiting Settings > Permalinks and hitting save twice (yup, twice, it sounds weird, just go with it) and see if you are still experiencing these issues then?

    Pressing save (twice) resulted in .htaccess in the root of my site being updated. But, this in turn resulted in server errors, as WordPress added redirect rules at the end of the .htaccess file, though a caching plugin puts a lot of ‘stuff’ at the start of .htaccess, the two apparently conflicting with each other.

    So, to get my site to work, I had to remove the (standard) WordPress additions at the end of the .htaccess file in the root of my site.

    After this, Gutenberg still fails in the same way, when trying to save a post.

    I’m indeed on 3.9.0.

    Moderator Marius L. J.

    (@clorith)

    Hey,

    You’re right, pressing save twice does re-write the .htaccess file, this is intended (although it will only modify its own rules unless the file has been improperly modified manually or by a plugin/theme).

    Any way, let’s take a step back then, what does your Site and Blog URLs under Settings > General look like?

    I have a caching plugin (WpFastestCache) that rewrites my .htaccess. It also has some leftover (but commented out) rules.

    WordPress address:
    https://mysite.com/wordpress

    Site address:
    https://mysite.com

    Moderator Marius L. J.

    (@clorith)

    I’m not able to replicate the issues you are experiencing with my test install in a subdirectory as yours.

    Have you tried following the troubleshooting steps outlined at https://wordpress.org/support/topic/known-compatibility-issues-common-questions-and-how-to-report-bugs/#gutenberg-getting-support to make sure it’s not an issue caused by a plugin or theme conflict?

    I’ve installed the ‘health check & troubleshooting’ plugin, but I’m not at all clear how this could be helpful.

    I cleaned my .htaccess file of non-wp stuff (that is, old commented out lines). After this, Gutenberg both responded with ‘saved’ when pressing the ‘save draft’ button and ‘Updating failed’ (in red, underneath the header).

    Ii also started with an empty .htaccess file, letting WordPress and WP Fastest Cache fill the .htaccess file as they saw fit, but this resulted in the same situation: ‘saved’ and ‘updating failed’.

    Moderator Marius L. J.

    (@clorith)

    The Health Check plugin lets you use a Troubleshooting Mode (essentially letting you view your site as if it had no plugins, or plugins of your choosing, active and a default theme without affecting site visitors), either by visiting the Dashboard > Health Check pages, or by clicking the little Troubleshoot link by the Gutenberg plugin in the plugins list.

    I’m intrigued by something you mentioned in your last reply here though, you say you are getting both messages at once when you click to save the draft? Is the content actually saved if you try to view it (to try and identify which of the two messages is correct)?

    I’ll see what troubleshooting brings me and let you know.

    No, the content is not saved. I get a ‘saved draft’, or something like that, in my list of pages as a result.

    Just tried saving an entry now and having the same issues with Gutenburg not saving, no matter how many times I hit save.

    Had to revert to classic editor for now.

    MastaBaba

    (@mastababa)

    I just got around to using the Health Check plugin. Disabling all plugins, then reenabling only Gutenberg resulted in exactly the same; editing a page with Gutenberg and saving the draft resulted in both a red banner saying ‘Updating failed’ and the status indicator stating ‘Saved’.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.