Support » Plugin: DeepL Pro API translation plugin » Gutenberg not compatible

  • Resolved samlaflam

    (@samlaflam)


    Hi,

    I just purchased a DeepL API to use your plugin based on your last update who is supposed to be Gutenberg friendly, but it’s not.

    I have the error message “Gutenberg is not compatible with WPDeepL yet. Please use Classic Editor”

    I use your 1.5.0 version.

    How’s that possible ?

    Thanks for your help,
    Sam

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same Here?!

    Plugin Author Malaiac

    (@malaiac)

    v 1.5.2 should fix most of compatibility issues encountered with some Gutenberg installations.

    Hi @malaiac

    Thanks for this update, now with your 1.5.2 version I do have your block displaying but unfortunately the translation is not working. When I click on the “translate” button, a small waiting icon is running but nothing else happens. I waited more than 10 minutes to test, but nothing happened. I deactivated all my plugins, nothing changed. I tested it on Safari, Chrome and Firefox. I do have a proper API license.

    If you have any clue, It will be much appreciated.

    Sam

    Hi there, thank you very much for your 1.5.2 update.
    But I no hae the exact same behaviour here. I have this log messages:
    a:7:{s:4:”date”;s:19:”04/10/2020 10:50:02″;s:5:”class”;s:17:”DeepLApiTranslate”;s:6:”uniqid”;s:32:”6b7a910ed4ce67bfd28aac6d062ab3b8″;s:4:”type”;s:5:”fresh”;s:4:”mode”;s:4:”POST”;s:14:”response_error”;i:400;s:8:”response”;a:2:{s:4:”code”;i:400;s:7:”message”;s:11:”Bad Request”;}}
    a:10:{s:4:”date”;s:19:”04/10/2020 10:50:16″;s:5:”class”;s:13:”DeepLApiUsage”;s:6:”uniqid”;b:0;s:4:”type”;s:5:”fresh”;s:4:”mode”;s:3:”GET”;s:17:”request_microtime”;d:0.19454097747802734375;s:4:”args”;a:0:{}s:8:”response”;a:2:{s:15:”character_count”;i:0;s:15:”character_limit”;i:2500000;}s:15:”response_length”;i:47;s:12:”why_no_cache”;s:17:”Cache not allowed”;}
    a:10:{s:4:”date”;s:19:”04/10/2020 10:52:05″;s:5:”class”;s:13:”DeepLApiUsage”;s:6:”uniqid”;b:0;s:4:”type”;s:5:”fresh”;s:4:”mode”;s:3:”GET”;s:17:”request_microtime”;d:0.2100689411163330078125;s:4:”args”;a:0:{}s:8:”response”;a:2:{s:15:”character_count”;i:0;s:15:”character_limit”;i:2500000;}s:15:”response_length”;i:47;s:12:”why_no_cache”;s:17:”Cache not allowed”;}
    a:10:{s:4:”date”;s:19:”04/10/2020 10:52:49″;s:5:”class”;s:13:”DeepLApiUsage”;s:6:”uniqid”;b:0;s:4:”type”;s:5:”fresh”;s:4:”mode”;s:3:”GET”;s:17:”request_microtime”;d:0.1484391689300537109375;s:4:”args”;a:0:{}s:8:”response”;a:2:{s:15:”character_count”;i:0;s:15:”character_limit”;i:2500000;}s:15:”response_length”;i:47;s:12:”why_no_cache”;s:17:”Cache not allowed”;}
    a:10:{s:4:”date”;s:19:”04/10/2020 10:52:54″;s:5:”class”;s:13:”DeepLApiUsage”;s:6:”uniqid”;b:0;s:4:”type”;s:5:”fresh”;s:4:”mode”;s:3:”GET”;s:17:”request_microtime”;d:0.156591892242431640625;s:4:”args”;a:0:{}s:8:”response”;a:2:{s:15:”character_count”;i:0;s:15:”character_limit”;i:2500000;}s:15:”response_length”;i:47;s:12:”why_no_cache”;s:17:”Cache not allowed”;

    • This reply was modified 3 months, 2 weeks ago by derfabi2020.
    • This reply was modified 3 months, 2 weeks ago by derfabi2020.

    Hi,

    Same problem as @samlaflam

    Since this last Week-end, when I click on the “translate” button, a small waiting icon is running but nothing else happens….

    Thanks

    Plugin Author Malaiac

    (@malaiac)

    Mmmm. I tested on three different installations and it worked :/

    Do you get any console output when translating ? (Shift Ctrl I in Chrome)

    @malaiac I see nothing in the console, the section “Error” is empty and I have 2 “Warnings” that are not related to your plugin when “translating”.

    I tried a radical test switching to “Twenty Twenty” theme and deactivating every plugins except yours, but it changed nothing.

    Same for me again :

    I use 2 websites and the problem is the same both…

    I have 2 errors :

    Uncaught TypeError: jQuery(…).live is not a function
    at post.php:4696
    at post.php:4783

    tagdiv-theme-plugins-setup.js:249 Uncaught TypeError: Cannot read property ‘getEditedPostContent’ of null
    at window.tdYoastSEOUpdateContent (tagdiv-theme-plugins-setup.js:249)
    at tagdiv-theme-plugins-setup.js:281
    at dispatch (jquery.js:3)
    at r.handle (jquery.js:3)

    Hey !

    I got this error message in the console :

    Uncaught TypeError: Cannot read property 'cached' of undefined
        at Object.success (deepl-metabox.js?ver=5.5.1:72)
        at i (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.1:2)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.1:2)
        at x (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.1:4)
        at XMLHttpRequest.c (load-scripts.php?c=0&load[chunk_0]=jquery-core,utils&ver=5.5.1:4)

    Hey there,

    With new update, it’s working for me now.

    But trying to translate a existing post with images, it’s messing up everything, it’s transforming images block to other type of block, and messing up the text format…

    Plugin Author Malaiac

    (@malaiac)

    @samlaflam could you provide me with sample content ? My name at gmail for the mail

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.