Support » Fixing WordPress » Gutenberg: Missing Comments Section when editing post

  • Resolved lynnek424

    (@lynnek424)


    Hello,
    We’re running WP 5.04 and when we enable gutenberg (by deactivating the classic editor plugin), the comments section that is normally displayed when editing a post, are not displayed. We’ve tried updating to WP 5.1.1, with the same results. There are no errors/warnings written to the php debug log.
    There is no screen option to hide/show comments in the options menu. We do still see the Discussion section in Gutenberg and comments are enabled for the post.
    Help?
    -Lynne

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    When you edit a document in the new block editor, you’ll see the Discussion options in the Document settings to the right of the editor: https://cld.wthms.co/JCt8lM

    If you do not see that section, click the vertical 3 dots icon the top-right, and scroll down to “Options”: https://cld.wthms.co/32Orrj

    From there, check “Discussion” to display the Discussion settings: https://cld.wthms.co/kvREd2

    Thread Starter lynnek424

    (@lynnek424)

    Hi James,

    Yes, I do see the discussion options in the right side of the editor, just fine.

    What I don’t see is the ‘Comments’ section that used to appear in the main column, that LISTS the comments associated to the post. Again, the Comments section appears fine, when the classic editor plugin is active. But, the Comments section does not appear when the classic editor plugin turned off so that Gutenberg is enabled.

    -Lynne

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Oh yes, that’s intentional. The interface is not part of the new editor.

    To see comments for a specific post or page, go to the Posts or Pages section of the Dashboard, and click the comments icon for the desired post or page: https://cld.wthms.co/rcwg4q

    Hello there,
    In some cases it’s better to have the comment list directly on the post edit screen. I don’t understand why this option has been removed, it’s just an option, deactivated by default :/
    The custom fields metabox is back in the option panel, so why not the comments?

    @macmanx Concerning your suggestion, that only allows you to reply to existing comments.

    It doesn’t allow you to add new non-reply comments to a post/page … which is something you can do in the classic editor.

    The omission is a curious one, and a poor choice IMO. It requires more clicks to do things associated with a post.

    Queremos los comentarios de vuelta! đŸ™‚

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Gutenberg: Missing Comments Section when editing post’ is closed to new replies.