Support » Theme: Pinnacle » Gutenberg issues?

  • Resolved lauratraveler

    (@lauratraveler)


    Hi,

    I’ve updated to Guthenberg but the image block is acting weird and it’s impossible for me to center the image. Basically, the image looks aligned centered in the dashboard but once I publish the post, the image shows aligned to the left. The HTML for these blocks looks like this <div class="wp-block-image"><figure class="aligncenter is-resized"><a href="link" target="_blank" rel="noreferrer noopener"><img src="link" alt="" class="wp-image-number" width="516" height="318"/></a></figure></div> so everything looks right to me and I can’t figure out what the problem is.

    The media + text block is even worse. The little pen icon I get when hovering over the image takes me to the media library so I cannot add a link to the image. The edit HTML option is only available for the text. Plus a few other issues too…

    Basically, I was wondering if these are still Guthenberg bugs that need to be sorted out in a future update…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey,

    Can you please post a link to this so I can see how the image is being output?

    The new editor does indeed have some improvements to be made. If you’re having too much difficulty there’s always the option to install the classic editor plugin to retain the original editor.

    https://wordpress.org/plugins/classic-editor/

    -Kevin

    Sure, here’s a link https://www.bylauraiancu.com/gift-guide-bloggers-creatives-entrepreneurs. Basically, all images should be centered, yet all of them are aligned to the left.

    Yes, it seems like some improvements are still needed, but wanted to give it a try. I haven’t installed the classic editor plugin yet, but right now I don’t even have the option to create posts in the new editor, which is utterly weird. Heard other people saying some of the options keep on appearing and disappearing. For me, it seems like the whole new editor is gone right now, except for this post I linked to above.

    Thanks, Kevin, for looking into this 🙂

    As a temp fix, try adding this CSS to Theme Options> Custom CSS:

    .wp-block-image > .aligncenter {
        text-align: center;
    }

    This should be fixed in the next update.

    -Kevin

    Thanks, Kevin. The CSS centers the images added via a link, however, the ones added through the media library are still not being centered.

    Oh, and one more question about the media + text block this time… is it normal behavior for it to be way wider than the post container when not using the wide options?

    Thanks!

    Try this CSS for the images with links:

    .wp-block-image .aligncenter > a > img {
        text-align: center !important;
        float: none;
        margin-right: auto;
        margin-left: auto;
    }

    Let me know if that works for you!

    -Kevin

    Yes, it does! Thank you, Kevin! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Gutenberg issues?’ is closed to new replies.