Support » Plugin: Gutenberg » Good but can be interrupted by third party plugins

  • updated

    After finding out that a simple (not really needed) third party plugin caused trouble on my working experience I am back using Gutenberg and rating it up. I wished Matt gave a more constructive feedback on my complain instead just not discussing it and going into defense. Of course I am embracing the new editor and suggest all users that are still having problems to review all plugins used to eliminate the problem.

    old review:

    I cannot really imagine that we will be forced to use Gutenberg soon. The way it is now is very confusing. I am very bothered with the setting block for the layout that is overlapping the text I am writing. I don’t know how to get rid of it.

    I feel like a laboratory rat dor WordPress. I cannot focus on my articles that way.

    • This topic was modified 1 year, 4 months ago by t-p.
    • This topic was modified 1 year, 4 months ago by Kuya Andy.
    • This topic was modified 1 year, 4 months ago by Kuya Andy.
    • This topic was modified 1 year, 4 months ago by Kuya Andy.
Viewing 8 replies - 1 through 8 (of 8 total)
  • You will not be forced, you can install the Classic Editor plugin (which we also made) and when you update to 5.0 you’ll stay on the same editing experience you have today.

    Alright, I thought I was reading that I won’t have a choice anymore once 5.0 is out. Gutenberg is maybe not bad, but the flying setting fir the layout is covering text blocks that still need editing. That is what is bothering most. Can’t find any setting for that.

    samdev

    (@tricksindia)

    @matt it will be forced one day because developers can’t keep plugins and themes compatible with both editors in long run. Many future themes might not include support for classic editor.

    So, users who have problems with the UI and/or users who experience issues (image jumps to top in classic block e.g.) with block editor or see incompatibility with (3rd party or WordPress) plugins/themes they all switch to classic editor.
    Or we can also say: they are forced to switch to classic editor otherwise they could not work with their website(s).

    These users will have a working WordPress with the Classic Editor, but who will then report bugs or incompatibility with the Block Editor @matt?

    The block editor has over a million sites using it already, so not worried about test or usage coverage. We made the Classic Editor plugin to give people a choice to hold back even while the default experience moves forward.

    Hi Matt, I am sorry your answer comes a bit arrogant along. I am willing to use Gutenberg and I didn’t mean it is all bad, but there is an issue that is making it bothering to use and I was explaining the problem. But you just went into defense instead to pick the issue up and to discuss, maybe even trying to eliminate it is much more helpful than to call users that are facing issues kind of underdogs (people that are holding on the old for example). Maybe other “millions” of users don’t have that problem, but seeing the reviews here the number of users with issues seems growing. I really didn’t expect an answer like that from you. I am not holding back on the classic editor, I just cannot use Gutenberg without having trouble.

    • This reply was modified 1 year, 4 months ago by Kuya Andy.
    • This reply was modified 1 year, 4 months ago by Kuya Andy.

    update

    The problem was caused by a third party plugin. It’s not your fault. I am going back to Gutenberg now, with a sour feeling as your feedback felt pretty unprofessional to me.

    I changed/corrected my review already.

    • This reply was modified 1 year, 4 months ago by Kuya Andy.
    • This reply was modified 1 year, 4 months ago by Kuya Andy.
    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Don’t feel too bad, it happens and reviews are there to be amended. If something turns sour again then feel free to go back to a negative rating 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Good but can be interrupted by third party plugins’ is closed to new replies.