• Hello,

    I was working at my page, saving wasn’t an issue, but after few minutes, saving didn’t work anymore. Only the Error with the JSON-Answer is coming. I tested already few things and the Classic Editor works. But i want, that the Gutenberg works, like it should. Anyone had that issue, too, or knows what to do?

    • This topic was modified 4 years, 3 months ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not a Requests and Feedback topic
Viewing 15 replies - 1 through 15 (of 18 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and switch to the default Twenty Twenty theme. If the problem goes away, enable them one by one to identify the source of the problem.

    If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Thread Starter wi_VOID

    (@sp8iky)

    Sorry for my late answer,

    Just checked it again. It’s kinda weird…
    If the lenght of the page is shortend, it’s working without any Problems, so it has to be the lenght. Do you know if there is a limit?

    I will test the Plugin Health Check. Thanks for your help!

    EDIT: After aktivating that Plugin, when all Plugins are deactivated and the Theme is the basic one, the error still occurs.

    • This reply was modified 4 years, 3 months ago by wi_VOID.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    There is no character limit that we know of.

    Try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    Thread Starter wi_VOID

    (@sp8iky)

    Ok i jsut did that. Still the same error…
    Any other idea?

    UPDATE: Now it’s even worse. Now actually every page is failing, like the one.

    • This reply was modified 4 years, 3 months ago by wi_VOID.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, please make sure that your browser is up to date: https://browsehappy.com/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    Thread Starter wi_VOID

    (@sp8iky)

    Tried that already, too.

    I tried:
    – Firefox: 70.0.1
    – Google Chrome: 79.0.3945.88
    – Safari: Can’t look it up right now.

    I deleted the cache from all 3 (different PC’s). Still same error.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    How about Firefox 71?

    Thread Starter wi_VOID

    (@sp8iky)

    Still not working.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    What version of PHP are you running, and who is your hosting provider?

    Thread Starter wi_VOID

    (@sp8iky)

    Sorry for my late answer.

    PHP: 7.3 (Tried already changing to 7.4 -> still same error)
    Hosting: Strato

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, ok, are you also running the Gutenberg plugin? The editor is built-in now, the plugin is just a testing ground for new features and bug fixes.

    If so, any improvement with it off?

    If not, any improvement with it on?

    Thread Starter wi_VOID

    (@sp8iky)

    I just installed and activated it.
    – No Improvement

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Are you running any server-side security, like mod_security or a firewall, or a security reverse-proxy, like Cloudflare or Sucuri?

    If so, would you please try with those off?

    Thread Starter wi_VOID

    (@sp8iky)

    I think i do not have one. But I’m not quite sure…
    If I’m only have my provider, usually i do not have one or do I?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    You can check with your hosting provider’s support, they’ll let you know.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Gutenberg: Error while saving (The JSON-Answer is not a valid answer’ is closed to new replies.