Support » Fixing WordPress » Gutenberg Error when creating or editing posts

  • Today I went to create a new post on my site and received back the following:

    TypeError: Cannot read property 'select' of undefined
        at http://localhost/wp-includes/js/dist/editor.min.js?ver=007:55:120501
        at n.value (http://localhost/wp-includes/js/dist/data.min.js?ver=007:1:14919)
        at new n (http://localhost/wp-includes/js/dist/data.min.js?ver=007:1:14614)
        at zf (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:69:258)
        at Mf (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:87:4)
        at ph (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:98:474)
        at eg (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:125:307)
        at fg (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:126:168)
        at wc (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:138:237)
        at gg (http://localhost/wp-includes/js/dist/vendor/react-dom.min.js?ver=007:135:160)

    Upon a quick Google search I discovered other users have had this same exact problem in Gutenberg but all of their posts are marked “resolved” despite there being no resolution.

    I can’t provide steps to reproduce this issue given I’ve never had it until today (only thing different today was updating the ‘Twenty’ themes).

    The problem “fixed” itself when I installed the Classic Editor plugin, so this bug is specific to Gutenberg and the fact that other users are getting the same error means it is a bug (albeit likely affecting a small group of users). Something with react-dom.min.js seems to be the issue as I reinstalled WP 5.0.2 twice and received the same error (with all 3rd party plugins disabled).

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Gutenberg Error when creating or editing posts’ is closed to new replies.