Support » Plugin: Gutenberg » Gutenberg editor not working

  • Resolved drtonyb

    (@drtonyb)



    The lastest release 2.5.0 of Gutenberg (and the previous) have not worked for me at all. When I try to edit a page, sometimes I get the message:

    ‘The editor has encountered an unexpected error.’

    The ‘Try to Recover’ option does nothing.

    Most times, all I get is a completely blank area where the editor should be.

    Finding that Gutenberg is not much use at all! Shame, as the concept is promising.

    I am testing on a multisite development environment and have tried activating Gutenberg on individual sites and network wide without much luck. Version 2.3.0 seemed to work, but not since.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Sorry to read that 2.3 worked but 2.5 doesn’t.

    When you encountered the blank screeen, did you happen to catch the error message(s) in the browser console? In Chrome via Menu > Other Tools > Developer Tools > Console?
    Or when you get the message “The editor has encountered an unexpected error”? It might provide more details as to the component, which caused the error.

    Hello Birgit,

    Thanks for your reply. Your suggestion to check the error in the browser Console (in my case Firefox) has lead me to the cause of the problem. It was code I had recently added to my own plugin, which I have now found wasn’t doing what I had planned it to do – it was inadvertently replacing ‘ with ” in scripts causing strings to terminate mid string resulting in multiple JS syntax errors. I have removed the code from my plugin and all is well.

    Thanks again,
    Tony

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Gutenberg editor not working’ is closed to new replies.