• Need help!!⚠️⚠️

    Can anyone please explain me..
    I am using Gutenberg WordPress editor for writing articles. Today when I added a new post, it is writing a post in a different font that I never used❌(new font). Whenever I preview the post it shows normal as a pre-used font✅.
    How to get rid of this issue? Any suggestions?

Viewing 9 replies - 1 through 9 (of 9 total)
  • I am using Gutenberg WordPress editor for writing articles. Today when I added a new post, it is writing a post in a different font that I never used❌(new font)

    Hi @menhairline typography is something that comes from the theme, if you are seeing a different font in the editor maybe there could be something conflicting with your site’s theme.json

    Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.
    If you are worried about how your site will look when you deactivate the plugin, you can use the Health Check plugin to troubleshoot your site Health Check

    triggame

    (@triggame)

    I can confirm that the plugin also breaks my font preview in the post and page editor screens. The font previews on the appearance editor and website frontend work fine.
    @menhairline did you find a solution?

    I can confirm that the plugin also breaks my font preview in the post and page editor screens.

    Hi @triggame I would suggest doing a conflict test as suggested in my previous reply. Reason being, I am not able to replicate this issue when I have the Twenty Twenty-Three theme and Gutenberg active on my site.

    triggame

    (@triggame)

    @thelmachido did you add your new font to the theme.json file? and did you compare the editor with and without the plugin active? The point is that the block editor works perfectly well with a new font added. As soon as you activate this “Gutenberg plugin” the fonts added to a child theme do not display in the block editor. The only reason I wanted this plugin is to use the new css grid blocks available. The current blocks only use flexbox for the rows and stacks.

    @thelmachido did you add your new font to the theme.json file? and did you compare the editor with and without the plugin active? The point is that the block editor works perfectly well with a new font added.

    Hi @triggame thanks for sharing more information about the issue, did you add the font to a theme.json file of a classic or block theme?

    Can you please share the name of the theme you are using and how you created the child theme? Additionally, does the issue persist when you are on the parent theme. That will help narrow down the issue.

    triggame

    (@triggame)

    Thanks for responding.
    Twenty Twenty-Three block theme with child theme. FSE displays new font perfectly with fonts added. Post editor and Page editor also display fonts perfectly when added. Its only when you activate the “gutenberg plugin” does the font display break in the post and page editor. The full site editor is not affected.

    Twenty Twenty-Three block theme with child theme. FSE displays new font perfectly with fonts added. Post editor and Page editor also display fonts perfectly when added.

    Hi @triggame that’s helpful, might I ask how you created the child theme?
    I would suggest using the Create Block Theme plugin to create the child theme, the plugin also has an option to add fonts to the site. So you can use it for both options and see if the issue persists thereafter?

    A.u.b. in WP editor Gutenberg versie 6.2.2 thema Shapely van Colorlib. Waar verander ik de lettertype en kleur van al mijn teksten?

    Hi @menhairline I would suggest opening a new thread for your issue to get assistance. The conversation on this thread is about the font type being different in the editor and frontend of the site, if you want to know how to add a new font to your site you need to open a new thread on the forum.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Gutenberg Editor Font Changed’ is closed to new replies.