Support » Plugin: Download Monitor » Gutenberg Download Button Block

  • Resolved csasser

    (@csasser)


    Having the following issues on new update with Gutenberg block on multiple sites.

    Get “Update Failed” error when the editor tries to autosave.
    Unable to edit html in Gutenberg.
    Download Button automatically applies rel=”nofollow”. (and block editor has no option to remove and since you cannot edit in html, you still can’t remove)

    So what I continue to do is just use download url directly and not use any shortcodes, templates, or Gutenberg block.

    Using version 4.2.0 with WP 5.0.3 on WPEngine with php 7.2.x. and latest version of Google Chrome on Desktop Windows 10 Laptop.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Barry Kooij

    (@barrykooij)

    Hey @csasser ,

    Thanks for your report and I’m sorry to hear that. Your support requests seem to contain multiple reports, so I’ll reply to them separately below.

    Get “Update Failed” error when the editor tries to autosave.
    Unable to edit html in Gutenberg.

    This shouldn’t happen indeed. I suspect that there is a plugin or theme conflict on your website. Could you please try if the error still occurs with only this plugin activated with a default WordPress theme (e.g. twentyfifteen). I understand this can be a bit of a hassle but it’s the only way we can be sure it’s a bug in this plugin.

    Download Button automatically applies rel=”nofollow”. (and block editor has no option to remove and since you cannot edit in html, you still can’t remove)
    This is correct. Our buttons and links have had this for a long time. This is to ask search engines to not index the direct download URL. If you wish to remove this, you can customize any template we include by overriding it. You can read more on how to do this here: https://www.download-monitor.com/kb/overriding-content-templates/

    Kind Regards,

    Barry Kooij

    Thanks @barrykooij

    So I decided before I turned everything off and switched themes and disabled all my plugins, I would repeat the sequence that generated the “update failed” error. Yes it repeated, but then I decided to select a different document from the blocks dropdown, the second document worked. BIG Surprise. Then I went back to the first document to see if the error would repeat again on the same document but it worked as intended the second time. I have now tried all my documents and can no longer reproduce the error. Go figure. 🙂

    I think I understand the nofollow better now and why I will leave it.

    Thanks for your detailed reply.

    We love the plugin and I have tried and tested many others.

    All the best,

    Charlie Sasser

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey Charlie,

    Thanks for the update.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Gutenberg Download Button Block’ is closed to new replies.