Support » Plugin: Shortcake (Shortcode UI) » Gutenberg Compatibility Issue

  • Bill Erickson

    (@billerickson)


    When Shortcode UI is active in WordPress 5.0 or higher, it triggers a php notice:

    > PHP Notice: edit_form_advanced is deprecated since version 5.0.0! Use block_editor_meta_box_hidden_fields instead. This action is still supported in the classic editor, but is deprecated in the block editor.

    This PHP notice then triggers Gutenberg to load in “Quirks Mode”, which leads to additional issues like metaboxes appearing on top of blocks in the editor. Shortcode UI must be deactivated to make the block editor usable.

    Here’s a detailed report on the issue: https://github.com/WordPress/gutenberg/issues/12598

  • You must be logged in to reply to this topic.