Support » Plugin: WP Media folders » Gutenberg button block and WP Media Folder issue

  • Anonymous User 17818406

    (@anonymized-17818406)


    Hi,

    I will explain the case just for others who have the same problem, but I also explain the solution here.

    When I create a “button” block with Gutenberg, I copy-paste the file url for the link which from the Media gallery. This folders are virtual (with the plugin WP Media Folder from Joomunited) but also real in server using your plugin. The button is not working as it is trying to find the file in /uploads and not in the real folder in server (/uploads/folder/subfolder).

    The solution, if it is not clear in the documentation of Joomunited plugin, is:

    1. Going to Settings of that plugin (not the ones of this plugin) and activate “Activate sync” (IMPORTANT, DO NOT activate “2 ways sync” or you will see in your Media gallery all the thumbnails that wordpress generates for the images, this can be very confusing; you can use this button maybe at first stages of working, uploading files massively, but then you should turn it off)
    2. then, select one folder in “server folders” (left tree) and the correspondent in Virtual folders tree (right); press “Add”.
    3. Do the same with the rest of folders that you want, one by one. PLEASE NOTICE that syncing one folder affects also its subfolders, so you don’t have to “Add” them manually one by one.

    I have set 1 minute delay cause the time of 60 minutes delay by default is strange.

    Hope it helps!

    • This topic was modified 6 months ago by Anonymous User 17818406.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Thread Starter Anonymous User 17818406

    (@anonymized-17818406)

    I add, its better to leave the delay syncing time to 60 minutes (default). If I set to 1 minute, the way wordpress works creating thumbnails can cause some of them not appear in their proper folder, but in /uploads (root) folder.

Viewing 1 replies (of 1 total)
  • The topic ‘Gutenberg button block and WP Media Folder issue’ is closed to new replies.