Support » Fixing WordPress » Gutenberg Autosave doesn’t work

  • Hi

    On my WordPress Blog (Version 5.1), Gutenberg does not autosave.
    What can I do to fix this? The REST API seems to be active. No caching Plugins are used.

    Thanks, Benjamin

Viewing 10 replies - 1 through 10 (of 10 total)
  • I just opened the Developer Tools in Google Chrome and found this:

    It seems that Gutenberg is doing the autosave, I see this calls with a “200” reply from the Webserver:

    https://www.mysite.com/wp-json/wp/v2/posts/2579/autosaves?_locale=user

    However, I see no “Saved” Status in the Editor. There are no Error messages in the Javascript Console. To check whether Autosave is done, I have to close the Window, it displays a Warning when the Text is not saved.

    Moderator Marius L. J.

    (@clorith)

    Hiya,

    I’m wondering if there might be a plugin or theme conflict that’s blocking the notifications from showing like they should, have you tried testing for this? (If you don’t have a staging setup, and don’t want to do this live, you can use Troubleshooting Mode in the Health Check plugin to not affect site visitors).

    Hello Marius

    Many thanks for your reply. I tested all Plugins and you’re right. The problem occurs when one Plugin is active – maybe I’ve found a Bug: When the Classic Editor is active, Autosave in Gutenberg won’t work. Or, to be more accurate, the Text gets saved, but the Message “Saved” is not displayed.

    I deacticated the Classic Editor Plugin, now everything works. However, from time to time, I need the CE to edit old Posts. It would be great if this can be fixed.

    Kind regards, Benjamin

    Moderator Marius L. J.

    (@clorith)

    Glad to hear you found the reason on your end, but I’m not able to replicate the problem when enabling just the Classic Editor plugin, so we may be looking at an interaction that involves a 3rd party as well to make it “tick”. Unfortunately, without being able to replicate the problem, there’s nothing we can do with the Classic Editor plugin to resolve this.

    Hallo Marius

    Thanks for your reply. Please try enabling the Jetpack Plugin. I have problems with both of them.

    Kind regards, Benjamin

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    I’m not able to replicate the problem either, using WordPress 5.1, Jetpack 7.0.1, and Classic Editor 1.4.

    Have you considered using just the Classic block inside Gutenberg instead? https://gogutenberg.com/blocks/classic/

    Also, what version of PHP are you running?

    Hi James and Marius

    Many thanks for your reply. I’m sorry You could not replicate the problem!
    The steps to reproduce here are very simple:

    1. Disable all plugins – Autosave in Gutenberg works
    2. Enable Jetpack and connect – Aotosave won’t work, (Text gets saved after ~30 Seconds but there is no message displayed and when I click away, WP freezes for ~5-10 seconds, no JS errors in the Console)
    2. Disable Jetpack – Autosave works again

    * I use PHP 7.2.10 (ubuntu0.18.04.1)
    * This is a very old WP Instance, it dates back to February 2005
    * No Autosave problems in the classic Editor
    * No commercial Themy, the Site uses a Twenty Twelve Theme
    Didn’t have this Problem in WordPress 5.0.3

    For safety, I’m going back to the Classic Editor.

    Many thanks for helping me, I appreciate it very much.
    Kind regards, Benjamin

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    I still can’t reproduce the problem following the steps you listed. Can you check under the Twenty Nineteen theme too?

    Hello James

    Many thanks for your reply.
    I tried Twenty Nineteen, Twenty Seventeen and the legacy Kubrick Theme, which was the default Theme when I installed WordPress. Unfortunately, that didn’t solve the problem. It seems not to be theme-related.

    I also checked the Webserver Log and found that WordPress in fact is sending an POST request to save:

    “POST /wp-json/wp/v2/posts/2591/autosaves?_locale=user HTTP/1.1” 200 9341 “https://www.*****.ch/wp-admin/post.php?post=2591&action=edit”

    And when the POST request invokes, I see this error message in the Javascript Console:

    WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Invalid frame header

    Kind regards, Benjamin

    Hello again

    I tried to find a way to replicate this problem. To do this, I installed WordPress ( 5.1–de_CH) from Scratch (newly extracted Files from Install Image, new MySQL DB). Everything worked fine on the new Setup, even after installing the Jetpack Plugin (7.0.1) – everything was ok.

    Used Browser:
    Google Chrome 72 (current Stable Channel)
    Firefox 65.0.1
    Server: PHP-FPM 7.2.15, Apache/2.4.37, Ubuntu 18.04.1 LTS

    After configuring Jetpack (logging in using a WordPress.com account), the “Saved” message still popped up. However, after ~1 hour, the problem described above appeared: After opening an Page in the Gutenberg Editor, changes are saved, but there is no message “Saved” in the Editor. Clickiong away freezes the Dashboard for ~5 Seconds.

    I repeated the steps described in this Post with the same result. In my humble oppinion, there is a Bug in Gutenberg, but it’s not simple to reproduce it!

    Kind regards, Benjamin

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Gutenberg Autosave doesn’t work’ is closed to new replies.