Support » Plugin: Gwolle Guestbook » Guestbook entries not submitted (Something went wrong saving the record)

  • Resolved burgenfreund


    Gwolle refuses to work on my page.
    Neither the error tests passed successfuly nor the sending of a test-record will work on my homepage. In this case, a message “Entschuldigung, es ging etwas schief bei der Speicherung dieses Eintrags. Bitte kontaktiere den Administrator.” is shown.
    Please advice.

    Standard-Test: 👎 Fehlgeschlagen.
    Emoji-Test: 👎 Fehlgeschlagen.

    Dieser Test wird zwei Einträge erstellen, einen mit Standardtext und einen mit Emojis.

    WordPress-Version: 5.0.2 (db: 43764)

    WordPress Theme: Impreza

    Aktive Plugins: Array ( [0] => foogallery-premium/foogallery.php [1] => 2j-slideshow/2jslideshow.php [2] => 2jslideshowkey/2jslideshowkey.php [3] => 7.0-965egj/b2b-market.php [4] => advanced-wp-columns/advanced-wp-columns.php [5] => autodescription/autodescription.php [6] => borlabs-cookie/borlabs-cookie.php [7] => classic-editor/classic-editor.php [8] => codelights-shortcodes-and-widgets/codelights.php [9] => contact-form-7/wp-contact-form-7.php [10] => duplicate-page/duplicatepage.php [11] => elementor-pro/elementor-pro.php [12] => elementor/elementor.php [13] => foobox-image-lightbox/foobox-free.php [14] => ga-germanized/ga-germanized.php [15] => google-sitemap-generator/sitemap.php [16] => gwolle-gb/gwolle-gb.php [17] => heartbeat-control/heartbeat-control.php [18] => html5-audio-player/html5-audio-player.php [19] => kv-tinymce-editor-fonts/kv_fonts.php [20] => media-file-renamer/media-file-renamer.php [21] => media-library-assistant/index.php [22] => modal-for-elementor/modal-for-elementor.php [23] => my-wp-health-check/mlw_health_check.php [24] => optimus/optimus.php [25] => real-media-library/index.php [26] => revslider-gallery-addon/revslider-gallery-addon.php [27] => revslider/revslider.php [28] => sangar-slider-addon-post-slider/sangar-slider-addon-post-slider.php [29] => sangar-slider/sangar-slider.php [30] => search-exclude/search-exclude.php [31] => shariff/shariff.php [32] => statify-widget/statify-widget.php [33] => statify/statify.php [34] => us-header-builder/us-header-builder.php [35] => woocommerce-gateway-paypal-express-checkout/woocommerce-gateway-paypal-express-checkout.php [36] => woocommerce-german-market/WooCommerce-German-Market.php [37] => woocommerce/woocommerce.php [38] => wp-google-maps-pro/wp-google-maps-pro.php [39] => wp-google-maps/wpGoogleMaps.php [40] => wp-staging-pro/wp-staging-pro.php [41] => wplr-sync-folders/index.php [42] => wplr-sync/wplr-sync.php )

    PHP-Version: 7.0.33-0+deb9u1

    MySQL-Version: 5.7.19-17-57

    MySQL-Zeichensatz: MySQL-Zeichensatz: utf8mb4

    MySQL / MySQLi: mysqli

    MySQL-Variablen: Array ( [character_set_client] => utf8mb4 [character_set_connection] => utf8mb4 [character_set_database] => utf8mb4 [character_set_filesystem] => binary [character_set_results] => utf8mb4 [character_set_server] => latin1 [character_set_system] => utf8 [character_sets_dir] => /usr/share/mysql/charsets/ )

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Marcel Pol


    Hi Peter,
    That is very unfortunate.
    In most cases the creation of database tables was unsuccesfull, that way no data can be stored.
    Could it be you are hosting on Microsoft Azure?

    Otherwise, could you check if the database tables gwolle_gb_entries and gwolle_gb_log do exist? Maybe you can go to Guestbook > Settings, do the uninstall, and then activate the plugin again.
    Also, make sure your mysql user has all the rights to the database.

    Thread Starter burgenfreund


    Dear Marcel
    This is an awesome response time. Never expected a get a reply on a Sunday.

    My Hoster is t-online (german telecom, not MS Azure)

    I found a gbwoll_gb_entry (not entries) in the Frontend-folder.
    However, a gwolle_gb_log was not found. Or did I miss a secret place?

    I followed your advice and deactivated and reactivated the plugin. The error-tests still show the same unsatisfying result.

    Your last line is not understood. I’m so far the only user and admin with all rights.

    Hope that this is not the end oft the efforts. Do you think that installing the PRO version “overwrites” a possible error and leads to successful operation?

    Best wishes for a happy New Year

    Plugin Author Marcel Pol


    Hi peter,
    There is some misunderstanding.
    The files are there, that part is fine. The data is stored in the database. You can use something like PHPmyadmin to get access to that. It might be available in the hosting panel of your hosting provider.
    The plugin uses its own database tables, and I suspect they are not there.

    The mysql user is the user inside the MySQL database, and separate from your WordPress account or hosting panel.
    It might be a good thing to involve the support helpdesk of t-online, they might easily see what the problem is.

    The Pro version, or add-on is only an extra plugin. You don’t need it for basic functionality.

    If it does turn out that your hosting provider doesn’t support MyISAM database tables, and only supports InnoDB (then they will tell you) you could be fine with the development version of the pluin. That has moved to InnoDB.
    If the support helpdesk confirms that that is the problem, then you can get that from:

    Plugin Author Marcel Pol


    Oh, and best wishes too for the new year 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Guestbook entries not submitted (Something went wrong saving the record)’ is closed to new replies.