WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Guest user post also showing Admin as author

[Resolved] Guest user post also showing Admin as author

  • Hello,

    You plugin is working exactly like the way I want it to be but the only problem is that If a guest user posts a post then in back end it is showing “Admin” as Author. Let me know how could I resolve this issue. I wanted it to be tagged something like “Guest” or “Guest User” in place of admin as author.

    Please check the screenshot – Screenshot

    http://wordpress.org/extend/plugins/guest-posts/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Babar

    @ibabar

    Yes, It saves posts under Admin username (or UID 1) by default.

    It has been designed to review and reassign to proper author (If needed) the post before publishing.

    If you want it to be specific user automatically, you will have use the author parameter.
    Guess your desired authors user ID is: 5, your shortcode will be [guest-posts author=5]

    When I have a guest post come through, it is not showing who the author is who filled out the guest post form.

    I have the same issue that swapnesh had where it automatically gets posted under admin, or in this case my name. But my problem is how do I know who actually wrote the post to give them credit?

    Do I have a setting wrong?

    Plugin Author Babar

    @ibabar

    The author name is saved under author custom field.
    Check out the editing screen of custom field.

    I am still not quite sure what you mean. Can you elaborate on the author custom field?

    I have done a few “test” guest posts and all of them post as pending articles under my name instead of the name that was entered under the YOUR NAME section of the guest post form. When I look at the different author options from dashboard, there is no way to tell who wrote (nor email contact) unless they were to put that in the body of the post.

    Does it have to be edited in the plugin? Does it have anything to do with this coding from the plugin files?:

    //Post Properties
    $new_post = array(
    ‘post_title’ => $title,
    ‘post_content’ => $story,
    ‘post_category’ => $category, // Usable for custom taxonomies too
    ‘tags_input’ => $tags,
    ‘post_status’ => ‘pending’, // Choose: publish, preview, future, draft, etc.
    ‘post_type’ => ‘post’, //’post’,page’ or use a custom post type if you want to
    ‘post_author’ => $authorid //Author ID
    );
    //save the new post
    $pid = wp_insert_post($new_post);

    /* Insert Form data into Custom Fields */
    add_post_meta($pid, ‘author’, $author, true);
    add_post_meta($pid, ‘author-email’, $email, true);
    add_post_meta($pid, ‘author-website’, $site, true);

    Plugin Author Babar

    @ibabar

    On post editing screen check this out:

    View post on imgur.com

    Thanks. I now see that my problem is I don’t have the custom fields option on my post editing screen. Any idea how I get this?

    Plugin Author Babar

    @ibabar

    Awesome, okay making progress now. So my custom fields are now showing. I entered custom fields of author, author-email, and author-website just like you have on your screen shot.

    What value do I use to have it pull in the author’s information once they complete the guest post form?

    Plugin Author Babar

    @ibabar

    Got it! Thanks, and test seem to be working now.

    I would like to thank you very much for all your assistance and quick responses!!

    Plugin Author Babar

    @ibabar

    🙂

    Hi there.
    I want to set the real Author of eahc post too, but I didn’t understand how to use get-post-meta…
    We have to put the code on page with [guest-posts] ?
    thank you for any help.

    up…

    I have a similar issue as above, and I followed the posted solution up to showing custom fields.

    When I select Screen options, it’s not giving me a choice of Custom Fields but only: Author, Categories, Tags & Comments.

    Do I need to update something?

    Ok, I found the right page, displayed custom fields. Now how do I get it to show the guest blogger instead of the admin?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Guest user post also showing Admin as author’ is closed to new replies.