Support » Plugin: Translate Wordpress with GTranslate » GTranslate not working

  • Resolved comftablynum

    (@cumfnum)


    No flags showing in drop-down menu and the languages aren’t changing when clicked on.

    Someone from GTranslate has worked on this and fixed it a few times now via FTP sharing and it keeps happening, he did something in the code but it keeps reverting back to faulty.

    The settings are all set right and I just don’t know what to do to fix it.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author edo888

    (@edo888)

    Hi,

    I have checked and I can see that when it tries to load the flag image it receives a 403 forbidden error.

    Please check the browser console network tab to see more details.

    You will need to check your web server access logs and find out what triggers 403 forbidden error when loading flags and make sure it is allowed to load them. If you are having troubles finding a solution, please consult your hosting provider, they should have the answers for you.

    If we have ever solved the exact same issue for you previously I’m sure we have provided details of what was modified, so you can follow the steps later.

    This is not a plugin specific issue, it is your webserver configuration issue which does not allow loading images. It might be caused by some firewall plugin.

    Thanks! 🙂

    Thread Starter comftablynum

    (@cumfnum)

    Hi, I’m still having the same problems after talking to my Host provider.

    Using Chrome:
    https://mycorner.online/ –The flags aren’t showing and the languages don’t change
    https://thepeopleproject.org.uk/ –The flags SHOW and the languages don’t change.

    Looking at the same sites using Firefox things are different. On mycorner site the languages are changing but the flags aren’t showing and on the people project site the flags are showing and the languages are changing, yet when using Chrome the languages don’t change on both sites.

    I’ve been talking to my host provider who have lifted the Bot traffic limit and have cleared any Cache problems and recommend to raise this with GTranslate support as you will have a better idea of debugging this.

    I’d love the flags and languages to show and change on both sites on both browsers.

    On another thread about flags not showing I saw this answer… “Please add the following rule to your CSS file”

    .flag.nturl > img {
    display: inline;
    }

    I don’t know where to add it or if I need to? If I do need to can you tell me where this code should go in a WordPress installation?

    If I’ve missed any information that you need, I’m sorry and please ask, and thanks!

    • This reply was modified 9 months, 1 week ago by comftablynum.
    Plugin Author edo888

    (@edo888)

    Hi,

    https://mycorner.online/ – flags do not show because of a 403 forbidden error when it tries to load the flags, you need to follow my suggestions and report your findings if you need further help. For example, did you check your server access/error log for 403 error? The selector works fine for me, I’m able to select a language and get a translation.

    https://thepeopleproject.org.uk/ – I see the flags and translations are also fine. Make sure that you are not logged in into the admin area when you test, best if you test with incognito mode and all browser plugins disabled if you have any. You will need to find out the difference when it works and when it doesn’t. I believe it is simply because of you are logged in and the page is different (has more scripts, has javascript errors, etc.). Please open a separate support topic for each issue you are having.

    Every support request is specific, so solutions provided on other treads may not apply to you. This is not the case a CSS rule can solve it for you.

    Thanks! 🙂

    Thread Starter comftablynum

    (@cumfnum)

    Hi,

    there are 403’s in the access logs but no errors.

    Plugin Author edo888

    (@edo888)

    Hi,

    You need to find out with your hosting provider what is causing the 403 errors for flag images (/wp-content/plugins/gtranslate/flags/24/en.png, /wp-content/plugins/gtranslate/flags/24/fr.png, etc.), there should not be 403 errors.

    It can be some firewall rule on their side, or it can be some rule in some of your .htaccess files in www root folder or inside wp-content or inside wp-content/plugins.

    If your hosting provider has no clue, I would recommend removing .htaccess files from wp-content/plugins and wp-content directories and making .htaccess file in your www root directory the default one provided by WordPress. Do not forget to do backups!

    If that does not help as well, then my suggestion would be to use Cloudflare’s free service for your website, so flags can be loaded from their servers instead of yours.

    Thanks! 🙂

    • This reply was modified 9 months, 1 week ago by edo888.
    Thread Starter comftablynum

    (@cumfnum)

    Thanks edo888,

    I have them working on it and I’ll let you know how it goes.

    • This reply was modified 9 months, 1 week ago by comftablynum.
    Thread Starter comftablynum

    (@cumfnum)

    @edo888 Thank you for your patience regarding this! It turns out it was due to an add-on that I had buried in the background that was causing the problem. Ghostry add-on.

    Thanks for your help 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘GTranslate not working’ is closed to new replies.