Support » Plugin: Translate Wordpress with GTranslate » GTranslate code doesn’t work

  • Resolved rodrigocs

    (@rodrigocs)


    Hello guys,

    I installed the Code Snippets plugin and entered the GTranslate code: https://prnt.sc/rtTUCFP4cjle

    <?php echo do_shortcode('[gtranslate]'); ?>

    Then, in a page I created with Elementor, I entered the shortcode [gtranslate], but the GTranslate menu does not appear on the page.: https://prnt.sc/zF_N4cdOrMoL

    Can you help me? Am I doing something wrong?

    Thank you!

    • This topic was modified 6 months, 1 week ago by rodrigocs.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author edo888

    (@edo888)

    Hi,

    I’m not sure what is the point of Code Snippets plugin here.

    Are you able to display “Hello World” in your desired location?

    Thanks! 🙂

    Plugin Author edo888

    (@edo888)

    Hi,

    I have not heard back from you. Please feel free to reopen this topic when you have time.

    Thanks! 🙂

    Thread Starter rodrigocs

    (@rodrigocs)

    Hi,

    The Code Snippets plugin I installed just to be able to insert your code, so I don’t need to insert it in the source code of the site, as it involves more knowledge.

    The process is basically like this, I insert the code below in the source code of the site, and then I insert the shortcode [gtranslate] where I want the GTranslate to appear, correct?

    <?php echo do_shortcode('[gtranslate]'); ?>

    I need to show the GTranslate widget on just one page. But when activating the plugin, the widget appears on every page of the site.
    If I’m going to use the shortcode to show the widget on just one page, then the plugin shouldn’t automatically show the widget on the entire site. How do I control this?

    Thank you!

    Plugin Author edo888

    (@edo888)

    Hi,

    If you can display “Hello World” text on your desired location on your website then you can simply change it to [gtranslate] and the language selector will appear, as simple as that.

    Note: If you display the language selector only on one page, only that page can be translated.

    Thanks! 🙂

    Thread Starter rodrigocs

    (@rodrigocs)

    As soon as I activate the plugin, the language selector automatically appears on every page on the site.

    How do I not show the language selector sitewide?
    If I’m going to use shortcode on just one page, then I need the plugin to not show the language selector on the entire site.

    Thank you!

    Plugin Author edo888

    (@edo888)

    Hi,

    Check the plugin settings, you probably have Show floating language selector or Show in menu option on.

    Thanks! 🙂

    Thread Starter rodrigocs

    (@rodrigocs)

    Thank you! 🙂

    Plugin Author edo888

    (@edo888)

    You are welcome! If you have a moment, please share your feedback about GTranslate and my support: https://wordpress.org/support/plugin/gtranslate/reviews/#new-post

    Thanks! 🙂

    Thread Starter rodrigocs

    (@rodrigocs)

    Done!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘GTranslate code doesn’t work’ is closed to new replies.